Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Perforce and have Workspace of project under Linux. The project contains many symbolic links. I have no problems with Perforce and the symbolic links as long as I work on Linux. However, if I mount the project via Samba to my Windows computer and if I create a Workspace to this Samba share, then the symbolic links break down. It looks like Perforce cannot read and write the symbolic links on my Samba share correctly.

Is there solution or workaround to force Perforce to create Linux compatible symbolic links on a Samba share?

share|improve this question
    
Which Windows version, and is Linux the server or the client? –  grawity Nov 15 '10 at 19:08
    
I am using Windowx XP SP3. Linux is the client, ie. I access Linux from Windows. –  stefangachter Nov 16 '10 at 13:39

1 Answer 1

Windows does not have native symlink support until Vista/7.


If you are connecting to a Windows share from Linux, try adding the sfu option to the mount command:

mount -t cifs -o sfu,(other options) //server/share /mountpoint

If you are running Perforce on Windows and connecting to a share on Linux, and your Windows version does not support symlinks, you cannot use them. (There's a slight chance Services for Unix can help, but I haven't used it much.)

share|improve this answer
    
Thanks for the comment. I am working under Windows XP and access a Linux server via Samba. So, there seems no solution so far. –  stefangachter Nov 16 '10 at 6:33
    
@stefan: In case of XP, my answer above applies: Windows XP does not have symlink support. –  grawity Nov 16 '10 at 14:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.