Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Arch Linux on my Packard Bell EasyNote TX86 (Intel HD Graphics, Core i5) and I can't control the backlight (it's always on max). xbacklight and writing to /sys/class/backlight does nothing. I tried

xrandr --output LVDS --set BACKLIGHT_CONTROL native

but it segfaults X with

Backtrace:
[   308.398] 0: /usr/bin/X (xorg_backtrace+0x3b) [0x80e685b]
[   308.398] 1: /usr/bin/X (0x8048000+0x64895) [0x80ac895]
[   308.398] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb770140c]
[   308.398] 3: /usr/bin/X (0x8048000+0xbe860) [0x8106860]
[   308.398] 4: /usr/bin/X (0x8048000+0x23e57) [0x806be57]
[   308.398] 5: /usr/bin/X (0x8048000+0x1a135) [0x8062135]
[   308.398] 6: /lib/libc.so.6 (__libc_start_main+0xe6) [0xb7442c76]
[   308.398] 7: /usr/bin/X (0x8048000+0x19d11) [0x8061d11]
[   308.398] Segmentation fault at address 0x48
[   308.398] 
Fatal server error:
[   308.398] Caught signal 11 (Segmentation fault). Server aborting

Ubuntu can't control it either, but Windows can. Any ideas? I'd love to use Linux full time but it eats my battery.

share|improve this question
    
You should probably to post this instead on the arch linux forums if you want a change to fix it. –  Herman Torjussen Jan 5 '12 at 21:39
    
I would suggest the same thing with @hesse. Also you can try different acpi settings, backlight is generally related to acpi. ACPI Modules @ ARCH Wiki –  Mavromatis Lozay Jan 19 '12 at 18:56

4 Answers 4

up vote 1 down vote accepted

This is no longer a problem, the kernel has supported it for a while.

share|improve this answer

I presume (hope) you're talking about keyboard backlight... in which case I used Ktoso's bash script script binded to a keyboard shortcut to get this working.

It worked for me in Arch but not in Ubuntu, but I no longer use Ubuntu so it's all good.

share|improve this answer
    
Actually I just realised you are definitely not talking about keyboard backlight... I'll leave my answer here just in case anyone thinks the same as me... –  a12jun Feb 22 '12 at 11:13

While this is less of a fix and more of a patch.. I personally used the 1st answer by Syzygy here. Bind all 3 of the scripts to certain key combos for easy adjustment.

share|improve this answer

I've had the same issue on my laptop with the past 2-3 versions of Ubuntu, but I've discovered a pretty quick fix. I have no idea if this'll work on Arch, but maybe it's worth a try?

Try editing /etc/default/grub and add following entry to GRUB_CMDLINE_LINUX_DEFAULT:

acpi_backlight=vendor

So the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" would now look something like GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

(You could also pass this to Grub during boot if you just want to try it once.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.