Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running a CentOS 5.3 x86_64 (fully updated as of today). It has a video card I cannot identify -- I run lspci and it identifies itself as:

01:00.0 VGA compatible controller: nVidia Corporation Unknown device 0615 (rev a2)

The previous admin left me with the linux driver and having installed that it seems to work properly in single monitor mode.

I have two identical monitors. Both are connected through DVI connectors on the back of the video card.

However when I try to enable dual-monitor mode through the Display menu applet, it doesn't work. The computer starts the NVidia driver and then kicks back to the command prompt.

The tail end of the Xorg.log file is:

0: X(xf86SigHandler+0x71) [0x4865b1]
1: /lib64/ [0x303de30280]
2: /usr/lib64/xorg/modules/ [0x2aedd36f803a]

Fatal server error:
Caught signal 4.  Server aborting

(II) Screen 0 shares mem & io resources
(II) Screen 1 shares mem & io resources

I have also done some fooling with the xorg.conf file directly such as duplicating the monitor definition between screens, but it always dies the same way.

Does anyone know how I might identify this card's chip properly to ensure I have the correct driver, and is there a good guide on the web anywhere for manually configuring two monitors off of one video card?

Thanks for any pointers.

share|improve this question
up vote 3 down vote accepted

Hah. I knew that as soon as I asked, I'd figure it out.

What I did:

  • in the Display applet, select Dual Head, the "second" video card, and Spanning Dekstops.
  • select a random LCD display that is sized appropriately.
  • exit X.
  • in /etc/xorg.conf: remove the second Monitor definition and duplicate the first Monitor definition. Rename the second Monitor definition to be Identifier "Monitor1".
  • in /etc/xorg.conf: Confirm the Device section for Videocard1 is correct -- the Display applet left it using the vesa instead of the nvidia driver.
  • in /etc/xorg.conf: I also deleted the resolution line, since it was 640x480.

Now it works.

I'd still be interested in how to identify the chip on the card, though.

Update, much later: this site lists the PCI device numbers for nVidia chips.

share|improve this answer

I was getting the same error message but this solution did not work for me. I fixed mine using the nvidia-settings GUI. In this GUI the second monitor was disabled, once I enabled it I got it to work. Also be sure to save the changes to the config file with the button provided.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .