Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have had a long-term ongoing battle in having nicely formatted emails sent in Thunderbird totally destroyed by MS Outlook. Are there any settings in either program which can resolve disagreements in layout and font selection?

By way of example, as a test I sent this:

alt text

and my coworker saw this:

alt text

The full source of the email sent is this:

From - Mon Nov 15 13:58:11 2010
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00800000
X-Mozilla-Keys:                                                                                 
Message-ID: <4CE1ACF1.2060804@***redacted***>
Date: Mon, 15 Nov 2010 13:58:09 -0800
From: ***redacted***
Organization: ***redacted***
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101027 Thunderbird/3.1.6
MIME-Version: 1.0
To: ***redacted***
Subject: Font used in email from me
X-Priority: 5 (Lowest)
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: 7bit

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
  <head>

    <meta http-equiv="content-type" content="text/html; charset=UTF-8">
  </head>
  <body bgcolor="#ffffff" text="#000000">
    <span id="IDstID">***redacted***,<br>
      <br>
      Could you please email me the screen shot of this email so I can
      see it as it appears to you, just big enough to include all the
      text vertically, and to cause wrapping horizontally.<br>
      <br>
      Indented paragraph:<br>
    </span>
    <blockquote>Sans-serif variable pitch font, indented.<br>
    </blockquote>
    A List:<br>
    <ul>
      <li>Bullet One</li>
      <li>Bullet Two</li>
    </ul>
    Preformatted:<br>
    <blockquote>
      <pre>Fixed pitch preformat text indented. <tt>Blah,</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt></pre>
    </blockquote>
    Fixed Pitch, Flowing:<br>
    <blockquote><tt>Fixed pitch flowing text, indented. Blah,</tt><tt>
        blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt>
        blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt>
        blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt>
        blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt>
        blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt>
        blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt>
        blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt>
        blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt>
        blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt><tt>
        blah</tt><tt> blah</tt><tt> blah</tt><tt> blah</tt></blockquote>
    <span id="IDstID">-- <br>
      ***redacted***<br>
      ***redacted***<br>
      <a class="moz-txt-link-freetext" href="http://www.***redacted***.com">http://www.***redacted***.com</a><br>
    </span>
  </body>

</html>
share|improve this question
    
One thing might help in identifying this issue is to compare the full headers for emails sent from Outlook to Thunderbird, and vice-versa. Outlook may be setting/expecting a header that Thunderbird does not normally set. Since these look to be HTML/RTF emails, something about the Content-type or encoding used might be useful in getting more information. –  xorbyte Nov 15 '10 at 23:35
    
Content-type for outgoing mail is set for UTF-8 in Thunderbird. These are newly composed emails, and not replies or forwards. –  Lawrence Dol Nov 15 '10 at 23:41
    
I've added the email source, which shows such things as content type, encoding and TB versions. –  Lawrence Dol Nov 15 '10 at 23:47

2 Answers 2

This helped for me:

Using two plugins, SmartTemplate (or SmartTemplate4 for TB 4+) and QuoteAndComposeManager, you can fine-tune the templates Thunderbird uses whether creating new mails, replies or forwards. A full rundown on how to change the Thunderbird messages to look like outlook-style can be found at the blog Be excellent to each other: How to Setup Replies in Thunderbird like Outlook.

Note: you'll need to do some tweaking and trying before it really works. I.e., when you don't use an inline style for a <td> element, it will render ugly on Outlook and on a returned mail (usually from Arial to Times). It's also recommended that you wrap the templates in a <font> block, because the Thunderbird editor will automatically place the cursor after the font-tag, but not after a div-tag (if that's the first tag in your template).

Information on other template uses and add-ins can be found here at Mozillazine, I haven't tried them, however.

As an example, here's what I've put in the Reply template, tweak it to your liking, the redundant span/font tags are to keep TB happy. It's still not perfect, but closest it can get for now, I think:

<font face="Helvetica, Arial, sans-serif" size="3"><span style="font-size:10pt;font-family:Arial, Helvetica, sans-serif;"> <br />
  <br>
  Cheers, <br />
  <br>
  Abel Braaksma
  </span>
</font>
<br />
<br />


<hr style="height:1px;border:none;color:black;background-color:black" />
<table style="font-size:10pt;font-family:Arial, Helvetica, sans-serif;" cellspacing="0" cellpadding="0">
  <tr>
    <th align="left" style="font-size:10pt;font-family:Arial, Helvetica, sans-serif;">From:</th>
    <td style="font-size:10pt;font-family:Arial, Helvetica, sans-serif;">%from%</td>
  </tr>
  <tr>
    <th align="left" style="font-size:10pt;font-family:Arial, Helvetica, sans-serif;">Sent:</th>
    <td style="font-size:10pt;font-family:Arial, Helvetica, sans-serif;">%datelocal%</td>
  </tr>
  <tr>
    <th align="left" style="font-size:10pt;font-family:Arial, Helvetica, sans-serif;">To:</th>
    <td style="font-size:10pt;font-family:Arial, Helvetica, sans-serif;">%to(name)%</td>
  </tr>
  <tr>
    <th align="left" style="font-size:10pt;font-family:Arial, Helvetica, sans-serif;">Cc:</th>
    <td style="font-size:10pt;font-family:Arial, Helvetica, sans-serif;">%cc(name)%</td>
  </tr>
  <tr>
    <th align="left" style="font-size:10pt;font-family:Arial, Helvetica, sans-serif;">Subject: &nbsp;</th>
    <td style="font-size:10pt;font-family:Arial, Helvetica, sans-serif;">%subject%</td>
  </tr>
</table>
<br />
<br />
share|improve this answer
    
This is not at all what I am talking about. Look at the two screenshots and the complete mess that Outlook makes of the email sent from TB. In particular, you'll note that email sent by TB contains no styling information at all, but one received from Outlook is chock full of (crappy) styling and fonts. –  Lawrence Dol Jun 27 '11 at 17:59
    
@Software: The thing is, in my experience, Outlook messes up the email because by default, parts of the message are rendered in a certain way by TB, and this "default" way is not known by Outlook. By giving yourself more control (i.e., adding stylesheets for default P, DIV, TD etc fonts and sizes, bulleted lists and removing the ">" in replies, which is what these plugins do) you can make a message look the same in Outlook and in Thunderbird. But it takes a bit of experimenting to reach that point. –  Abel Jun 28 '11 at 8:26
    
@Abel: OK, fair enough; if you edit this into your answer as a clarification I'll be able to remove my downvote. –  Lawrence Dol Jun 29 '11 at 0:25
    
@Software: I expanded and added a few of my own experience. In all fairness, it is still a pain, but once setup it works reasonably well. –  Abel Jun 29 '11 at 8:25
    
@Abel: So, using SmartTemplate, which I already have installed, where would I put the styling information, and what would that look like - do you have an example that you've used successfully? –  Lawrence Dol Jun 29 '11 at 21:48
up vote 0 down vote accepted

As it turns out, there is a relatively simple solution to this.

Never use "Body Text" for your email's top-level body, always use "Paragraph". I use the SmartTemplate4 add-on, so I set up templates along the line of:

<p>...</p>
<p>-- </br>
<b>Lawrence Dol</b></br>
http://SoftwareMonkey.org</p>

The leading elipses was necessary to stop Thunderbird throwing away the (otherwise) empty paragraph.

So when I start an email, I just highlight and overwrite the ellipses and it starts off in paragraph mode right away. (All other methods I could find to make TB use paragraph mode by default failed, though they undoubtedly worked for some people for at least some TB versions.)

What I like about this solution most is that it requires no CSS hacks; my email, as sent, is beautiful, plain, unadorned HTML.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.