Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I loaded an entire Samba drive as a TextMate project.

Every single time I lose cursor of TextMate to do something else like checking the web browser... and then try to click on TextMate again it gives me a spinning beach ball for 3 seconds.

I was wondering if there was a setting that would make it faster to focus the cursor in TextMate without the 3 second wait each time.

Also of note, if I open the files one at a time and not as an entire project, I don't get this problem, so I assume it has something to do with the number of files loaded in a TextMate project.

share|improve this question
    
Is this share on your network? It may simply be a latency thing. When you connect to it in the Finder, do you get the same 3 second delay? Can you try another connection method like SSHFS? –  fideli Nov 16 '10 at 1:33
1  
You might also have Save files when focus is lost enabled in TextMate's preferences (under Advanced > Saving) which may involve a lot of work as it's trying to figure out what to save. Every time you go back to TextMate, it will also check to see if any of the files on disk have changes since the last window refresh, since it will try to load these seamlessly for you. –  xorbyte Nov 16 '10 at 1:36
    
Well the network is very fast, I think it's just the sheer amount of files that TextMate checks. Save files when focus is lost is disabled, that was the first thing I thought of. I think TextMate tries to check the files for consistency each time on focus regardless... unfortunately I can't find where to disable that. –  resopollution Nov 17 '10 at 0:30
add comment

1 Answer

There is a great little plugin that might help called ReMate. It stops TextMate from automatically checking all the files in the project for changes when TextMate gains focus again. I use it for working with remote drives mounted with FUSE as that had the some problem.

You can download it on Github https://github.com/ciaran/Remate

The plugin adds an new item in the window menu called "Disable Refresh on Regaining Focus", if you check it then things get nice and speedy.

While it is active if you want to manually refresh the files right click in the sidebar and choose "Refresh All Projects"

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.