Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Windows XP guest cannot browse the Internet. My host is Win 7 home premium.

What are the possible causes for this?

share|improve this question
    
How did you configure the networking? –  user3463 Nov 16 '10 at 4:09
add comment

2 Answers

Your networking on the Virtual Machine needs to be set to Bridged mode. To do this you must power down the guest OS and change the network adapters settings to Bridged.

This link has more details on Bridged Networking: http://www.virtualbox.org/manual/ch06.html#id471083

share|improve this answer
add comment

Configure the network settings to either use NAT or Bridged networking. NAT gives the machine a completely new address and works as a router. Bridged is when the host and guest connect to the network using separate IP addresses. Use either/or. Both should work in connecting you to the internet.

share|improve this answer
    
-1 for wrong: "Bridged is when the host and guest share the same IP address" –  ta.speot.is Apr 19 '11 at 3:58
    
Instead of downvoting, why did you not edit my post to fix it? –  paradd0x Apr 19 '11 at 18:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.