Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Opera set as my default web browser. (This is on a Windows 7 system.) Thus, when I click on a link in some external program, such as Thunderbird or Acrobat, the page loads in a new tab in my Opera window.

For some reason, the new tab that opens is always a private tab -- which means that it doesn't show up in my history or my closed-tabs list when I close it.

Why is this happening? Or, more to the point, how can I change my settings to make it not happen?

share|improve this question
    
I have same problem. I just remove that "%1" and it works :P –  user65816 Feb 2 '11 at 20:30
add comment

2 Answers

up vote 2 down vote accepted

My guess is that the Windows association for HTML file has somehow set Opera to launch with the "--newprivatetab" option. You might be able to get that fixed by opening Opera, going to Settings -> Preferences, and then to the Advanced tab. Go to Programs, and click the "Details" button. Click Select All and then OK.

Though, if you're not afraid of the registry, the actual value is kept at:

[HK_Classes_Root\Opera.HTML\shell\open\command]
share|improve this answer
1  
A good thought, but the value of that registry command is just "C:\Program Files (x86)\Opera\Opera.exe" "%1". Oddly, though, if I execute that from a command line, it doesn't open in a private tab.... –  Brooks Moses Nov 18 '10 at 5:05
1  
However, poking around a bit further -- I think what happened is that the HTTP and HTTPS URL associations (and not the HTML file associations) had gotten set weirdly. I went though the Windows Control-Panel "associate program with this extension/protocol" settings dialog box, and selected "Opera" for both of those (even though it appeared to already be set), and now things open in non-private tabs. So, problem solved. Thanks! –  Brooks Moses Nov 18 '10 at 5:16
    
@Brooks Ahah! A good find. –  SysAdmin1138 Nov 18 '10 at 6:07
1  
I had this issue with Opera 10.63 on Windows 7 too. I only noticed it a few days ago but didn't bother to fix it until I saw this question and solution. Does anyone know the cause of this? Is the fault on Opera's side, or Windows? –  galacticninja Nov 24 '10 at 7:30
    
I have same problem. I just remove that "%1" and it works :P –  user65816 Feb 2 '11 at 20:30
add comment

I had the same problem. My solution: Just open IE, make it the default browser. Then open Opera and re-choose Opera as the new default browser. That's it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.