Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My notepad won't show chinese characters, while other programs will. Why is that? How to fix it?

share|improve this question
add comment

3 Answers

Notepad is one of the most basic text editors there is, however, if you go to save as and change the document type to unicode when you save, it should be able to save the Chinese characters.

As for display - I am no expert in Chinese, I just went to Google Translate and copied and pasted a chunk of text, and put it in Notepad - not having any problems here.

share|improve this answer
    
Now I remember. Since text files have no metadata the encoding when opening a file is detected by an educated guess. So if you write bush hid the facts and save it as ANSI, when you open it again in Windows XP/NT/2000 it will display chinese characters because it thinks it's unicode –  Jader Dias Nov 16 '10 at 12:26
    
My Windows is in Portuguese-BR and it doesn't work even if I paste the text from Google translate –  Jader Dias Nov 16 '10 at 12:32
1  
@Vam'çá: It looks like the default font Notepad uses (Lucida Console) doesn't include Chinese characters. If you paste Chinese characters into Notepad, they will appear as boxes, but the correct character codes are stored internally. You can change Notepad's display font using FormatFont. My computer has three fonts with Chinese characters, MingLiU, MS Hei, and MS Song, maybe your computer has them too. –  Bavi_H Nov 17 '10 at 2:01
add comment
up vote 1 down vote accepted

As Bavi_H noted the issue is that the default font (Lucida Console) doesn't have chinese characters. He said

If you paste Chinese characters into Notepad, they will appear as boxes, but the correct character codes are stored internally. You can change Notepad's display font using Format → Font. My computer has three fonts with Chinese characters, MingLiU, MS Hei, and MS Song, maybe your computer has them too.

I noted that Times New Roman works for me.

share|improve this answer
add comment

When the Chinese characters appear as boxes, you can go to Control Panel and change the System Locale setting to China PRC. Restart your computer to activate the change and the Chinese characters will appear properly

share|improve this answer
    
"rendering fonts" is a bit different from "changing the locale of the system". to show some xyz chars on the screen one needs a font supporting the right glyphs. with a font lacking the needed glyphs nothing will change (look-alike-wise) when you change the locale. –  akira Oct 26 '12 at 6:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.