Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I run Photoshop CS4 on Windows 7, other running programs don't receive the ESC key (I noticed in PuTTY and Total Commander's Lister). When I close Photoshop, they start receiving the ESC key again.

  • I tried multiple keyboard layouts, no change.
  • Photoshop is an out-of-box install, no settings changed
  • I exported the list of keybindings from Photoshop (ctrl-alt-shift-k) and ESC isn't used in any combination

Why is this? Is there any way to disable or bypass this so that I could use other programs normally?

share|improve this question

5 Answers 5

up vote 18 down vote accepted

Photoshop CS4 and ATI Catalyst Control Center both hook the Escape key. To fix it, use Windows Task Manager to terminate ccc.exe and restart Photoshop.

share|improve this answer
3  
Thanks, it does work. This describes both the problem and solution accurately and works without the need to run an external program, therefore I chose it as the accepted answer. –  user46935 Feb 20 '11 at 9:51
    
(when in fact neither of them should mess with the Esc key...) –  romkyns Feb 27 '11 at 21:21
    
I think you can leave CCC running, but DISABLE hotkey support in the CCC menus –  horatio Jul 28 '11 at 14:53
3  
I just ran into the same problem, but with Intel's HD Graphics driver rather than CCC. (My machine uses both NVidia discrete GPU and onboard Intel SandyBridge GPU. Had no probs with NVidia only, but enabling Intel GPU as well made me see this problem when Photoshop was running.) -- To fix it I right-clicked Intel's tray icon, then chose Graphics Options, Hotkeys, Disable; then restarted Photoshop. Many thanks to all for pointing me towards the solution; hope this extra info helps someone else. –  Leo Davidson May 18 '12 at 13:01
1  
Thank you Leo, the intel solution worked for me! –  jlbruno Feb 5 '13 at 20:05

Intel chipset users should right-click on Intel Graphics tray icon and disable hotkeys.

Other way to do this (if Intel Graphics tray icon missing): Control panel -> Display -> Change display settings -> Advanced settings -> select tab "Intel® Graphics and Media control panel" -> press button "Graphics Propertries" -> Options and Support -> Hot Key functionality -> uncheck "Enable"

From here http://forums.adobe.com/message/1636488#1636488

share|improve this answer

It's a issue with the Photoshop and it happens on other programs too. (It's probably related to some Photoshops plugins) You should be able to use SHIFT+ESC to bypass it.

This issue is fixed in CS5.

You could also try one of these programs from here http://forums.adobe.com/message/1636461#1636461 if you are not happy with the SHIFT-method or upgrading to CS5.

share|improve this answer
    
Thanks. I tried PsEscFix.zip but it doesn't work with my Photoshop CS4 64-bit. I wouldn't want it hanging around all the time, anyway. The shift-ESC workaround is good enough for me until I get CS5 or later. –  user46935 Nov 16 '10 at 19:52
    
Shift+Esc might work in some cases, but usually does not. I mean it might close the odd menu, but programs that expect ESC won't respond to Shift+Esc. –  romkyns Sep 11 '11 at 15:11
    
The issue still occurred for me in CS5 64-bit, when CCC was also running. –  adurdin Feb 25 '12 at 10:38

The problem wasn't related to any other software in my case.

This is what helped me (Win 7 Professional x64, had no such problem with Win 7 Professional x86).

Run CS3 - esc did not work. Run CS3 in compatiblity mode with WinXP SP3 - that solved it, but no drag&drop into photoshop (due to different user rights maybe).

I turned off the compatibility mode and the ESC still works as it should :)

EDIT: not TRUE that it wasn't related to any other software. When I was testing it I already had Catalyst Control Center (CCC.exe) shut down from another round of testing. So CCC IS somehow involved in this problem. Simply turning off Keyboard shortcuts in CCC DID NOT work I had to shut it down (in my case via the TaskManager, but I guess normal quit would work the same, ie. not leaving some other part of CCC.exe running).

share|improve this answer

Photoshop CS3 (32-bits) on Windows 7, SP1

Photoshop itself can use Esc. For example, in open file dialog the Esc key will cancel/close the dialog.

But any other application such as notepad can not use Esc key.

At the same time, Ctrl+Shift+Esc still opens the task manager.

As a vim user, Esc is most frequently the key used to get back to normal mode. Inside vim CTRL+\ CTRL+N is a workaround to bypass the malfunctioned Esc.

If you close the Photoshop application, the Esc hook will be released and works again.

I use hotkey explorer utility to find out which application hooks what key.

How to Fix Photoshop Breaking the Escape Key in Windows

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.