Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a program set up to run via Windows Task Scheduler, but if the program is re-compiled then the execution of the program is tied up with the "This program has changed, allow it access to the network?" prompt (not verbatim). Is there a way to disable this or allow an exception for my program?

Also, please leave a comment on what that Windows feature is called. I don't quite know how to google for solutions to it.

share|improve this question
add comment

1 Answer

You don't say which version of Windows you are running, but the message reads like one that comes from a firewall program which is monitoring outgoing connections.

You need to find the options page for your firewall and see if there's an "always allow" option where you can specify an application.

Either that or run the program interactively the first time you recompile it.

share|improve this answer
    
Thanks - I thought it was a new feature in Vista but I found a "Network Threat Protection" thing in my Symantec Endpoint Protection software so I'll try disabling that and see if it works. Running it interactively is not really an option. –  weiji Nov 16 '10 at 23:27
    
@weiji - I'd be reluctant to disable it completely. It helps guard against malicious software being installed and "phoning home". –  ChrisF Nov 17 '10 at 8:48
    
Oh, I understand - but in my situation, it's okay as this is a work system, they have a lot of network-level devices and services to protect us. Thanks for the concern! –  weiji Nov 17 '10 at 20:17
1  
That is indeed a prompt from Symantec Endpoint Protection. I think if you go into the firewall rules configuration under Network Threat Protection and add your executable as an exception it should allow it without prompting whenever it changes. As long as you don't change the name anyway. –  Tofystedeth Nov 17 '10 at 20:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.