Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed BlackSheep on my MacBook. However, every few minutes, it prompts me to type in my password.

Is this a well-known problem? More to the point, is there way to use BlackSheep without needing to type in my password every few minutes?

~~Edit~~

So far, the only answer I've gotten that works is to log in as root. This seems like a case of the cure is worse than the disease. Isn't it a big security risk to be routinely running Firefox as root?

I would love it if someone knows a better way of getting around this...

share|improve this question

2 Answers 2

up vote 4 down vote accepted
+50

I would start by checking that you have the latest Update to BlackSheep from November 8.

In the article Firesheep, iancharnas comments:

For people receiving the --fix-permissions error, here's what to do:

  1. Under Applications -> Utilities open Terminal
  2. Copy-and-Paste this command into Terminal and hit [enter]

    sudo ~/Library/Application\ Support/Firefox/Profiles/*/extensions/firesheep\@codebutler.com/platform/Darwin_x86-gcc3/firesheep-backend --fix-permissions

  3. It will ask you for your password, type it in.

  4. Restart firefox and the error should go away.

If you still get the "--fix-permissions" error, you probably have FireVault installed and need to do the following. If you have FileVault enabled, it will mount your home directory as "nosuid", so the packet-capturing backend won't be able to run until you Copy-and-Paste these additional commands into the Terminal to move the firesheep-backend to a place it can run SUID root:

sudo mv ~/Library/Application\ Support/Firefox/Profiles/*/extensions/firesheep\@codebutler.com/platform/Darwin_x86-gcc3/firesheep-backend /usr/bin/firesheep-backend
sudo ln -s /usr/bin/firesheep-backend ~/Library/Application\Support/Firefox/Profiles/*/extensions/firesheep\@codebutler.com/platform/Darwin_x86-gcc3/firesheep-backend
share|improve this answer
    
Running firefox as root does stop it from happening. However, is it safe to just always run firefox as root? That seems like an extra security risk? –  David Oneill Nov 28 '10 at 4:19
    
I tried moving the extension folder from the profile to the application directory, and that didn't seem to solve the problem. I'm going to try that one again, but if you have any ideas on how to make that work, I'd appreciate that. –  David Oneill Nov 28 '10 at 4:24
    
I tried moving the extension again, to no avail. It still prompts for the password ever x min (where x is the frequency that it is set up to check) –  David Oneill Nov 28 '10 at 4:37
    
What about the guest account workaround? –  harrymc Nov 28 '10 at 8:05
1  
Also see comment by iancharnas here : codebutler.com/firesheep#comment_5843350 –  harrymc Nov 28 '10 at 9:39

I'm the author of BlackSheep. A few users reported this issue on Windows and Linux. Usually, this is caused by an AV or sandboxing program that prevents the browser from running an arbitrary executable. You might want to check if you have such program running.

share|improve this answer
    
Hmm... As I said in the original question, this is running on a MacBook. I don't have any AV software installed. I'm not sure if the Max OSX runs firefox in a sandbox by default, the solution that ended up working for me (see above) might be a clue about why this is happening. –  David Oneill Jul 15 '11 at 19:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.