Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have VS2008 and VS2010 installed on my box. I have a solution (the .sln file) that I use VS2008 for. When I double click on the solution, VS2008 opens it.

I would like to drag the solution to the taskbar and pin it there. However, when I drag over the taskbar, the tooltip says: Pin to VSLauncher.exe. When I finally pinned the solution, a VS2010 icon appears on the taskbar. Naturally when I launch it, the solution opens in VS2010.

How can I pin the solution to the taskbar and have it launch in VS2008?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

While this sure isn't ideal, I found that it works on my testing system.

You should create a batch file as follows:

@echo off

START "C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\IDE\devenv.exe" "Full\Path\To\ProjectFile.sln"

Remember that you have to select the correct path for the version of the executable you want to run. Remember to use the " " for pathnames that have spaces and weird characters ...

Save this anywhere you like.

Now, pin a shortcut to cmd.exe to the taskbar (type cmd.exe in the startmenu, right-click on it and select pin to taskbar.) Now, go to the newly created shortcut, right click on it, then right cick on Command Prompt and go to Properties. Here where it says target and type in:

%windir%\system32\cmd.exe /C "Path\To\The\Batch\File.bat"

Now, when you click on your Command Prompt shortcut in the taskbar, you will open your desired version of Visual Studio with the desired project.

Godd luck!

share|improve this answer
    
Yeah, I ended up doing this. It feels like a massive hack, though. Win7 should be able to do this. –  AngryHacker Nov 19 '10 at 0:28
    
Keep us updated to see if a more straight-forward solution pops ups! –  akseli Nov 19 '10 at 13:58

Pin the solution to the taskbar as you did.

Now, right-click on the icon that is created, go up to the Solution that you want to open in the pull-up menu and right-click on that. Now, go to the Properties, and click on Opens with ... here, select the Visual Studio 2008 executable from your Program Files folder.

Good luck!

share|improve this answer
    
I did exactly as you mentioned. However in the Open With dialog, I browse for the file and pick the one I want, but nothing changes in the dialog. It's possible that Always use the selected program to open this kind of file checkbox is grayed out. –  AngryHacker Nov 17 '10 at 0:14
    
@AngryHacker When you say you browse for the file, you are talking about the VisualStudio 2008 executable, right? Or are you looking for a different file? –  akseli Nov 17 '10 at 0:18
    
Yes, I am talking about browsing for VS2008 executable (devenv.exe) –  AngryHacker Nov 17 '10 at 0:27
    
I am thinking this is a wider problem of file associations not really working well in Windows 7 64bit. I found a ton of complaints. social.answers.microsoft.com/Forums/en-US/w7files/thread/… –  AngryHacker Nov 17 '10 at 0:28
    
@AngryHacker Hope they can fix the file association issues soon. But I've been going over how you could get this done in my head, and I've come up with a possible make-shift solution which may circumvent your problems... I added another answer to make it easier to read. –  akseli Nov 18 '10 at 2:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.