Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Upgrading firefox to 3.6.12 causes the Xorg process to run @ 100% CPU time.

  • OS is: Red Hat Enterprise Linux Client release 5.4 (Tikanga)
  • Previous version of firefox: 3.01
  • New version of firefox: 3.6.12
  • Other changes: upgraded libflashplayer.so from adobe website

Note that the previous version of firefox is still installed at /usr/bin - I have to start the new version of firefox using: ~/bin/firefox/firefox -no-remote.

As mentioned, when using firefox 3.6.12 with all add-ons disabled, something triggers the Xorg process to run @ 100% (as viewed by top) - memory consumption remains normal. For example, opening http://grigio.org/pimp_my_gedit_was_textmate_linux triggers this problem. Memory usage remains normal during this time. Opening up the same set of pages (as the session information is stored by my profile) using firefox 3.0.1 does not cause any problems.

share|improve this question
    
I've had no end of problems with 3.6.x versions of Firefox and finally switched to Chrome. –  tcrosley Nov 17 '10 at 0:46

1 Answer 1

You can try renaming (or removing) ~/.mozilla to see if it solves the problem. You can also un-install 3.6.12 and install 3.0.1 manually.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.