Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Ubuntu 8.04.4 server with an md RAID5 consisting of 9 drives. While transferring a large amount of data to it (through vsftpd) I noticed very bad transfer speed fluctuation.
For example during the transfer of a 20GB archive, every couple of 100MB, the transfer would completely halt for several seconds. Then it would go back up to ~55MB/s. And this would repeat over and over again; leaving me with an overall transfer speed of like 10MB/s.
The server is on the same 1Gb LAN as the machine I am working on, so I assume the LAN is not the problem.
I have observed this behavior on this server several times in the past whenever I have to transfer large data volumes (over 200MB).

Looking at the output of iostat, top or our Cacti graphs did not give me any indication to what might cause this issue.

Any idea on how to diagnose an issue like this would be appreciated.

share|improve this question
add comment

3 Answers

To be honest, I wouldn't use FTP transfers to measure speeds - it's an antiquated protocol, and I wouldn't be surprised if it was slowing you down.

Can you export a directory with NFS and try transferring the files that way?

share|improve this answer
    
Sure, I could do that. It would be helpful to see if the issue is related to vsftpd or the underlying layers. But, generally, I don't have this issue with other servers (which I access via FTP). So I should be able to resolve this with the current setup (hopefully). –  Oliver Salzburg Nov 17 '10 at 3:04
    
Ok, I tried it with a Samba share. Same behavior. So I don't think that level is the issue here. –  Oliver Salzburg Nov 17 '10 at 3:25
    
Well, I'm stumped, then. Sorry. –  user55325 Nov 17 '10 at 4:01
add comment

Both ftp and samba do not use compression. Use rysnc with --progress and -Z flags so that compression is used and progress is reported.

If large amount of data is not large number of files but few files with large size (>2GB) then issue could be related to sparse files.

Also check 'more /proc/mdstat' when speeds are slow to ensure that speeds are not slow due to re-syncing of md array.

share|improve this answer
    
I'm interfacing with the server usually from Windows workstations (so no rsync). The issue can also be observed when transferring a large amount of small files (the overall data volume seems to be important here). I checked mdstat during transfers; nothing changes in there. –  Oliver Salzburg Nov 17 '10 at 4:14
add comment
up vote 0 down vote accepted

I still have no idea what the root cause of the issue was. In the end I suspected the CPU of the system to be too weak (high load average, high cpu load).

Today I upgraded the system to Ubuntu 10.04 and the issue seems to have resolved itself. The performance is still not as stable as I would like it, but at average it has improved by at least a factor of 10.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.