Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I like the concepts of UAC and the "Secure Desktop" in Windows 7, but I don't like the dimming of the Secure Desktop to prompt for Admin credentials (or OK button to get clicked).

However, dimming goes so far that my monitor regularly goes into PowerSaver mode, which is annoying (as it takes another 10 seconds for it to wake up), and might harm the monitor: two weeks after switching from XP to Windows 7, my 30" monitor stayed black and it had to get replaced.

The web is full of tips how to turn off dimming, but that will always also turn off the "Secure Desktop".

Is there a way to present the Secure Desktop without dimming? Or with a different visual effect to show that it is the Secure Desktop?

EDIT: To clarify, I'm not looking for a way to disable dimming by disabling Secure Desktop (as is done by lowering the UAC level). I want to keep both UAC and Secure Desktop.

share|improve this question
    
I think the reason the desktop is dimmed is to highlight the UAC box. While disabling UAC would work it's not the answer to your question. Have you looked into seeing if there is a regisrty key which defines the colour and density of the dim? –  tombull89 Nov 17 '10 at 14:22
    
I've searched the web extensively and haven't found a way to keep UAC and "Secure Desktop" (SD) but not dim. Maybe you just cannot get SD without dimming? –  Florian Nov 18 '10 at 0:45
    
this will help : howtogeek.com/howto/windows-vista/… –  adi Feb 26 '12 at 15:46

3 Answers 3

up vote 7 down vote accepted

Ok, the thread is old, however, as I managed to find the solution for myself, I want to share it with everybody who like OP or me wanted UAC with Secure Desktop and ON but had problems of monitor/video modes switching. I'm on Windows 7 but I hope there's no difference to Vista for this solution to implement (can anybody try?).

The root cause of the problem (in my case at least) appeared to be slow switching to another video mode on Secure Desktop before dimming the screen. So, I looked for the way to find these settings somewhere then change them to more appropriate. As described here http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/windows-7-changes-screen-resolution-on-boot-up/13c17468-0d70-4827-a559-dca0fa558a69 the resolution and refresh settings are stored in multiple subkeys here:

HKEY_CURRENT_CONFIG\System\CurrentControlSet\Control\VIDEO

so all I had to do is get my current user settings from Control Panel -> Desktop -> Adjust resolution (note Resolution parameters) and then -> Advanced settings -> Monitor (note Screen refresh rate parameter). These parameters could be entered by regedit in all subkeys having values DefaultSettings.XResolution, DefaultSettings.YResolution and DefaultSettings.VRefresh. Now Secure Desktop (check it by Ctrl+Alt+Del) doesn't switch to different mode, so that unacceptable UAC delay stopped to bother me. Hope it can help.

P.S. Another approach that worked temporarily was switching to Secure Desktop by Ctrl+Alt+Del, pressing accessibility button and checking High Contrast option. In my case it worked till first logout, so if the first approach won't work, try to investigate more in this alternative direction.

share|improve this answer
    
Van, Superuser is a knowledge base, not a forum. We like it when people come up with new answers to old questions. –  Isaac Rabinovitch Nov 29 '12 at 21:32
    
This works! the UAC screen is dimmed, but it's so fast that the monitor will not go into sleep mode. Btw. my VRefresh setting was "1". I still changed it to 60, and it works. –  Florian Dec 3 '12 at 21:08
    
@Florian, 60 is a good generic choice for all LCD monitors. For old non-LCDs, however, things are way more complicated and 60 would be one of the worst (though still workable) VRefresh choice. I just hope, for purpose of the solution, not that many non-LCDs left in possession as part of personal workstations suitable for Vista/7. ^_^ –  Van Jone Dec 6 '12 at 22:10
    
Yet another observation: my monitor still may be a bit "thinky" for the first time it switches modes since its power on. But after this first occurrence it's satisfactory fast as long as in power on state. –  Van Jone Dec 6 '12 at 22:12
    
Is there a way to get this to work with different resolutions when using 2 different monitors (LCD and external, for example)? –  rustyx Sep 6 at 8:42

On Windows 7 search for "Change user account control settings" in the start menu and then move the slider to the position shown in the image. This will keep UAC enabled but won't dim the desktop.

alt text

share|improve this answer
2  
I completely skipped over your answer because I looked at the slider, but not the text next to it. Then I read the screen and was like really??!? -1 to Microsoft for bad layout, but +1 to you for finding it! –  Theo Nov 17 '10 at 14:42
    
wow, all the times I've just diabled UAC without realising that was there. +1 for you. –  tombull89 Nov 17 '10 at 17:44
    
Do you know how to change this in Vista? It seems to only have full on and full off for UAC. –  Dennis Williamson Nov 17 '10 at 18:15
2  
hi, sorry, this is not the right answer. Lowering UAC level to "not dim" mode will keep UAC, but will deactivate "Secure Desktop". The Secure Desktop prevents malware to spoof clicks, and to capture passwords. –  Florian Nov 18 '10 at 0:43
    
@Dennis I don't think there is a way of doing this in Vista –  starofale Nov 18 '10 at 15:07

Use this registry script to turn off Secure Desktop:

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
"PromptOnSecureDesktop"=dword:00000000

It is impossible to turn off dimming while keeping Secure Desktop. This is to keep users from asking „why doesn’t my desktop accept clicks?”.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.