Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is going to be a little difficult to explain. This is a problem that started recently, every thing was working fine up until two weeks ago. After starting Windows 7 and logging in (I log on with a non admin account) the tray icon which inform the status of networking has the small Windows "doing something" circle (I forgot how it's called...) on it but it doesn't rotate, it's stuck. Usually this will appear for a brief second while a network connection is being set up but lately it will stay in this state for about two minutes in which networking is not available. During this time I cannot run any action which requires administrative privileges, either directly through right clicking and "run as administrator" or for example opening the network and sharing center. Trying to do any of these actions results in the process or windows "hanging" until a certain point which is also when the little circle above the networking icon disappears, networking is available, and everything is running fine.

Event viewer doesn't list anything out of the ordinary. It feels as if some kind of action is taking place that blocks any other actions from being performed until the first one is completed, however I have no idea how to trace down what is the source of this problem.

There is no change if I log on with an Admin account, everything is the same as described above.

edit: I didn't investigate it fully but the problem turned out to be PostgreSQL. For some reason the postgress server would cause the network to hang as at startup.

share|improve this question
    
It would help to know how you connecting to the network: wired / wireless, network card model, router model, local network architecture. –  harrymc Nov 17 '10 at 14:35
    
@harrymc An onboard netowork card is connected to a router with a RJ45 cable –  user54921 Nov 17 '10 at 14:43
    
Exact same problem. Anyone has any ideas? –  Martin Argerami Aug 2 '12 at 4:05

2 Answers 2

The thread Network detection is slow at startup suggests:

  1. Verify the network card driver is up to date (from manufacturer's site)
  2. Verify that the problem still exists when booting in Safe mode
  3. Under Network adapters, right-click the adapter, select Properties, Advanced tab, disable "Receive side scaling". Several people there have reported that this solved their problem for wired connection.
share|improve this answer
    
It doesn't seem like the problem is network detection. It seems like network slow network detection is a side effect of the problem. –  user54921 Nov 17 '10 at 23:11
    
But have you tried the above? –  harrymc Nov 18 '10 at 5:51

Another thing you can try is:

 Start->Run
 Enter 'msconfig'

The msconfig program allows you to restart a system with (1) minimal Windows components, (2) Everything on, or (3) selective services to be started.

If you want to be sure that you do not touch any of the MS services, you can set a checkbox to prevent any modifications to the services.

My suggestion: set the system to minimal (exception of Windows services) and then see how things go after a reboot. Then using the selective option you can then add back the other services one-by-one until you find the klinker. I'm making the assumption that there is a possibly a service from another vendor that may be causing the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.