Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just tried restoring a 250MB database from a backup on my local machine, and got the following message:

TITLE: Microsoft SQL Server Management Studio Express
------------------------------

Restore failed for Server 'MULTIVIS-A0D9F3\SQLEXPRESS'.  (Microsoft.SqlServer.Express.Smo)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=9.00.3042.00&EvtSrc=Microsoft.SqlServer.Management.Smo.ExceptionTemplates.FailedOperationExceptionText&EvtID=Restore+Server&LinkId=20476

------------------------------
ADDITIONAL INFORMATION:

System.Data.SqlClient.SqlError: CREATE DATABASE or ALTER DATABASE failed because the resulting cumulative database size would exceed your licensed limit of 4096 MB per database. (Microsoft.SqlServer.Express.Smo)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=9.00.3042.00&LinkId=20476

------------------------------
BUTTONS:

OK
------------------------------

I had 3 db's on the machine, one ~4.1gb db and two other dbs < 10mb each. So I did some googling on this error and saw the suggestion to try shrinking my other dbs to free up some space. So I did so on the 4.1gb db and now when I go to 'properties' for that db it says it is taking/using ~2.4gb. So I should have space now I figure, but whenever I try to restore the ~250mb database now I still get the error message above.. I tried restarting as well but that wasn't helpful.

Any idea what the issue is?

share|improve this question
add comment

2 Answers 2

up vote 0 down vote accepted

When Microsoft writes software with a bug, there is no fixing it apparently..

share|improve this answer
    
You can upgrade to SQL Express 2008 R2 which raises the limit to 10 GB. –  vcsjones Dec 24 '10 at 0:15
add comment

I had the same error, my problem was that the initial size on the database that was backed up was 4098mb (this database has only been SQLExpress2005 so not sure how that happened) but had 3000mb data being used. (To see that bring up properties of the database and go to Files, or it is shown on the Shrink dialog too)

So the backup was trying to restore the backup with that same amount of unused space, but couldn't allocate it. Which to me was an error because the used space was far below the limit size, and the backup came from a SQLExpress2005 instance.

To fix it I had to shrink the original database and make a new backup, then I was able to restore it successfully. You'd think there would be a setting during restore you could set, or modify the backup file in some way, but I haven't found anything yet.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.