Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem connecting to the internet with a windows 7 computer. It is on a LAN and can communicate with other computers on the network. It can ping it's default gateway, which is an adsl router.

However when I ping google.com from the computer, it gets the following reply from it's gateway: "Destination net unreachable". This tells me it is indeed trying to use it's default gateway. The same problem occurs with all windows 7 computers on the network.

Networking on the LAN works just fine as the windows 7 computers can print over the network.

A windows XP machine on the network can connect to the internet via the router just fine.

share|improve this question
2  
It would help if you could post the results of "ipconfig /all" on one Win7 and one XP computer. –  harrymc Nov 18 '10 at 9:44

2 Answers 2

Perhaps something is causing Windows 7 to use IPv6 rather than IPv4? Try disabling IPv6 under Network and Connection Center → Manage network connections → Adapter properties

share|improve this answer
    
Thanks. I've tried that. No luck. –  Steve Nov 18 '10 at 9:00

A few suggestions:

  1. Do you need to connect to the Internet through a proxy?
  2. Have you checked on the router if you're getting an IP from your service provider?
  3. Is your pc IP on the same subnet as the gateway?
  4. Try disabling DHCP and giving your PC a static IP in the same subnet as your router.

If that doesn't work, I'm at a loss but I did find this. It might be of some use to you:

http://www.sevenforums.com/tutorials/18203-internet-troubleshooting-guide.html
http://www.tomshardware.com/forum/102-63-windows-internet-troubleshooting

I hope this helps.

share|improve this answer
    
a) No proxy needed. b) There is a working internet connection. c) Yes d) I will try that, though I don't see how it'll help. The IP I get via DHCP works on the LAN. Intenet connectivity is the problem Please note that a win XP computer on the same network connects to the internet just fine. –  Steve Nov 18 '10 at 8:55
    
Darn. I don't suppose the Network Troubleshooter helped? I saw a post on the MS site mentioning Winsock could be corrupt but all it suggests on fixing it is to click Troubleshoot problems. –  QuiXilver Nov 18 '10 at 9:19
    
Nah, the network troubleshooter has never solved anything for me. –  Steve Nov 18 '10 at 9:29
    
try to edit your answers rather than adding new ones, please –  Jeff Atwood Nov 18 '10 at 10:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.