Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm exploring the accessibility features within Gnome and having trouble with Slow Keys. My input is always doubled. Press a key briefly and I get nothing as you'd expect. Press just a bit longer and which ever key I'm pressing is input twice. Hello becomes HHeelllloo.

I'm running Debian Lenny 5.0.6, kernel 2.6.26-2-686, GNOME Desktop 2.22.3 running within a VirtualBox session. I did some googling and didn't find others having similar troubles. Maybe it's a vbox thing? Any ideas how to fix this so I don't get the duplicates? It makes it impossible to log back in when the screen lock kicks on!

share|improve this question

2 Answers 2

I just got my new laptop and thought to change the controls for the keyboard and messed up the slow, repeat, delete,long press key strokes,and use of the arrow keys. I was able to correct my problem regaining delete and backspace speed. Example of my settings:

Repeat Keys
     X(click box) Key presses repeat when key is held down
Delay:  Short      ___________________________X___________________     Long
Speed:  Short      _____________X__________________________________    Long

I hope this helps everyone, if you copy the lines in exact length, this will also help to find the correct positions as the settings can be touchy when adjusting, this may be to prevent adjustment problems. Also when typing, it helps to realise that once a key is pressed, lift your finger; laptops are more sensitive than traditional typewriters. Good Luck solving all problems.

Edit: Fixed "settings" example formatting.

share|improve this answer

I have seen this before in the keyboard preferences, accessibilty tab, Slow Keys (only accept long keypresses) is checked and delay is set to long, while under the general tab - Repeat Keys (key presses repeat when key is held down) is also checked and not set to a long duration. There must be a key-command for it because the PC's owner didn't acknowledge setting it. This was on Ubuntu, version 9-something with gnome 2.3 something. I have also seen these settings in KDE, version 4 perhaps.

I believe in Ubuntu:gnome the packages are called gnome-control-center and gnome-settings-daemon

share|improve this answer
    
Thanks, but I haven't found a combination of options that works properly. I tried unchecking Repeat Keys and setting Slow Keys to both long and short durations: same result of duplicated keystroke entry. Same thing with Repeat Keys on, set to a very long delay, or very short duration. –  skypanther Nov 19 '10 at 14:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.