Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having curious (but somewhat fatal) behaviour of a HDD since yesterday night.

My pc was happily doing a backup of my photo collection from an internal HDD to an external one while I was reading on my bed and I heard the reset beep. I just ignored it (thought it was a voltage drop) since it was late but today when I woke up nothing seemed to work again.

My Win7 x64 failed to boot with strange errors:

  • black screen after windows loading screen (with mouse pointer on and functional)
  • black screen of death before windows loading screen complaining about an I/O error with a code 0xc00000e9
  • at BIOS boot a strange message related to the S.M.A.R.T. capabilities that were not working

So, starting from that, I plugged in Win7 DVD and from recovery console did a chkdsk /f on compromised disk. It started working but halted at some point, then I tried with dir command and he told me that it wasn't unable to fulfil my request because of an I/O error (mind that I tried the same thing before starting the scandisk and I was able to browse the whole directory structure).

So I tried with an Ubuntu 10.10 in live mode. It refuses to start if the compromised HD is plugged (without complaning about anything, just spinning icon forever after the choice of "Try it!") but it starts seamlessly if I detach the SATA connector.

Then I checked in bios about SATA configuration and I discovered that it was set to IDE, so I placed AHCI (this because I had an IDE hdd that I removed for now).

I've almost been able to run the whole chkdsk again but directly from windows boot options until it complained (after having found some file record segements unreadable) about the lack of space to apply corrections to the disk.

So what should I do? I would like to first find a way to backup the content of the HD (and free some space to run chkdsk) but it seems there's no way to boot with it plugged in.

share|improve this question
    
can you mount it via an external enclosure/adapter after booting the live CD? –  Xantec Nov 18 '10 at 19:58
    
Set the BIOS back to IDE emulation, at least for now: if Windows tries to boot but doesn't have the right AHCI drivers for your controller (which it may well not have as you've never had that mode turned on until now) it will get a short way in then fail as if the controller/drive can't be found at all. –  David Spillett Nov 18 '10 at 20:05
    
The hard drive or motherboard hard drive controller is failing, do as suggested by Xantec and connect the hard drive using a usb sata hard drive adapter, see if you can pull data off that way, you will need to replace the hard drive or possibly the motherboard in rare circumstances. –  Moab Nov 18 '10 at 20:29

3 Answers 3

up vote 1 down vote accepted

You almost certainly have a hard drive that has failed, is failing, or has bad blocks.

If you desperately want the data on it and can read it but not boot it, then you need to:

  • remove it, put it in an external enclosure (USB or eSATA)
  • buy a new HDD and install it
  • load your OS and apps all over again onto the new HDD

Then try and attach the old HDD via the external enclosure, see if it spins up, and if it can be seen then copy things off. This step is likely to fail but you won't know when or where - it depends on which parts of the drive have gone bad.

If you have an existing external drive (eg with your photo collection on) then DO NOT use this one to mess about / put into the machine / etc. Lock it up and treat it like gold, because it may be the only backup you have. Only when everything else is sorted out should you try and use that one again (apart perhaps from restoring data).

Oh - and re the AHCI / IDE setting: I generally leave it set to IDE. If you change an existing bootable disk from IDE to AHCI then you will get boot time crashes because the drivers are not present. AHCI should only be set when you are installing from media onto a new disk.

share|improve this answer

SMART is a monitoring protocol for computer hard disks. More info here. If you are getting SMART errors during POST, then you have a disk that is or is going bad.

I recommend you replace the disk as soon as you can and stop trying to run the old disk at all - the more you try to use it, the higher the chances it will completely die. Once you get your new disk, install your operating system on it, and use that as your primary disk. You can then plug in your old disk and try to access it to recover your data before it dies.

share|improve this answer

The last time I had unexplained intermittent problems, it was a motherboard failure. However, another likely suspect is a poor or under-powered power supply unit. The power supply problem can manifest even months after a new item of hardware is added to your system. Consider the power supply as possibly faulty if this is your case.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.