Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've compiled, installed new linux kernel, I'm getting errors while trying to boot it, Errors;
1. mount.ntfs : error while loading shared libraries : libfuse.so.2 can not open shared object file
2. could not mount the partition /dev/disk/by-UUID/C0C8F4B0C8F4A5B6 .... (filesystem ntfs, error code = 127)

I've updated grub with command update-grub my root fileSystem seems to be /host/ubuntu/disks/root.disk in fstab file. However when i execute command mount -l I get /dev/root0 as a root fileSystem. How must i configure the grub config file ? And what the first error is about ? is it related with the second one? Thanks for answers

/etc/fstab file;

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/host/ubuntu/disks/root.disk /               ext3    loop,errors=remount-ro 0       1
/host/ubuntu/disks/boot /boot           none    bind            0       0
/host/ubuntu/disks/swap.disk none            swap    loop,sw         0       0
/dev/sda2 /mnt/windows ntfs defaults 0 0
/dev/sda4 /mnt/backUp ntfs defaults 0 0

Output of the mount -l

root@ubuntu:/# mount -l
/dev/loop0 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
/dev/sda3 on /host type fuseblk (rw) [Xubuntu]
/host/ubuntu/disks/boot on /boot type none (rw,bind)
/dev/sda2 on /mnt/windows type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096) [Sony Vaio]
/dev/sda4 on /mnt/backUp type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096) [Back Up]

/boot/gurb/menu.lst

## ## End Default Options ##

title  Ubuntu 9.10, kernel 2.6.31.12
root  ()/ubuntu/disks
kernel  /boot/vmlinuz-2.6.31.12 root=UUID=C0C8F4B0C8F4A5B6 loop=/ubuntu/disks/root.disk ro quiet splash
initrd  /boot/initrd.img-2.6.31.12

title  Ubuntu 9.10, kernel 2.6.31.12 (recovery mode)
root  ()/ubuntu/disks
kernel  /boot/vmlinuz-2.6.31.12 root=UUID=C0C8F4B0C8F4A5B6 loop=/ubuntu/disks/root.disk ro  single
initrd  /boot/initrd.img-2.6.31.12

title  Ubuntu 9.10, kernel 2.6.31-22-generic
root  ()/ubuntu/disks
kernel  /boot/vmlinuz-2.6.31-22-generic root=UUID=C0C8F4B0C8F4A5B6 loop=/ubuntu/disks/root.disk ro quiet splash 
initrd  /boot/initrd.img-2.6.31-22-generic

title  Ubuntu 9.10, kernel 2.6.31-22-generic (recovery mode)
root  ()/ubuntu/disks
kernel  /boot/vmlinuz-2.6.31-22-generic root=UUID=C0C8F4B0C8F4A5B6 loop=/ubuntu/disks/root.disk ro  single
initrd  /boot/initrd.img-2.6.31-22-generic

title  Ubuntu 9.10, kernel 2.6.28-16-generic
root  ()/ubuntu/disks
kernel  /boot/vmlinuz-2.6.28-16-generic root=UUID=C0C8F4B0C8F4A5B6 loop=/ubuntu/disks/root.disk ro quiet splash 
initrd  /boot/initrd.img-2.6.28-16-generic

title  Ubuntu 9.10, kernel 2.6.28-16-generic (recovery mode)
root  ()/ubuntu/disks
kernel  /boot/vmlinuz-2.6.28-16-generic root=UUID=C0C8F4B0C8F4A5B6 loop=/ubuntu/disks/root.disk ro  single
initrd  /boot/initrd.img-2.6.28-16-generic

title  Ubuntu 9.10, kernel 2.6.28-11-generic
root  ()/ubuntu/disks
kernel  /boot/vmlinuz-2.6.28-11-generic root=UUID=C0C8F4B0C8F4A5B6 loop=/ubuntu/disks/root.disk ro quiet splash 
initrd  /boot/initrd.img-2.6.28-11-generic

title  Ubuntu 9.10, kernel 2.6.28-11-generic (recovery mode)
root  ()/ubuntu/disks
kernel  /boot/vmlinuz-2.6.28-11-generic root=UUID=C0C8F4B0C8F4A5B6 loop=/ubuntu/disks/root.disk ro  single
initrd  /boot/initrd.img-2.6.28-11-generic

title  Ubuntu 9.10, memtest86+
root  ()/ubuntu/disks
kernel  /boot/memtest86+.bin

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title  Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title  Windows Vista (loader)
rootnoverify (hd0,0)
savedefault
chainloader +1
share|improve this question

migrated from stackoverflow.com Nov 18 '10 at 23:01

This question came from our site for professional and enthusiast programmers.

    
This would be better asked at superuser.com. –  Nathan Ernst Nov 18 '10 at 22:45
add comment

1 Answer

So what this seems to me is that you have your Ubuntu installation on a NTFS drive, and somehow libfuse broken.

What you will have to do is to boot on an Ubuntu CD or something like that and chroot into the installation on the disk. This will hopefully allow you to reinstall fuse, which is the library allowing you to mount a NTFS formatted drive.

Chrooting can be done more or less like this:

  1. Boot into an Ubuntu Live CD
  2. Mount your device and note the mountpoint
  3. Mount dev, proc and sys with -o bind options to the mountpoint above

    ex: mount -o bind /dev /media/ntfs/dev

  4. Now chroot into the Ubuntu installation you have mounted:

    ex: chroot /media/ntfs /bin/bash

  5. Reinstall libfuse and fuse
  6. Reboot and see if that helps, hopefully it does.

That would be my approach, it might work for you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.