Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Redmine has to be restarted after a plugin installation.

How can I do that on linux? Does it mean to restart my web server (nginx in my case)? Or do I have to do something else?

share|improve this question

4 Answers 4

up vote 9 down vote accepted

Restart your webserver. How to do that depends on your webserver you installed Redmine in, and your Linux distribution. For Apache on Debian, I'd do a:

# /etc/init.d/apache restart
share|improve this answer
    
I run redmine on ngix and Ubunbu. Well if restarting webserver is what I need to do that I know how to restart web server already. –  Radek Nov 20 '10 at 11:31
touch /path/to/redmine/tmp/restart.txt

Redmine will restart at the next page request. This is often the only way if you're on an instance where you don't have permission to restart Apache (shared hosting, etc).

share|improve this answer
    
This seems to be the way how Phusion Passenger works: whenever you touch the tmp/restart.txt file, Passenger restarts all the Rails processes. I didn't manage to restart apache this way though, you would need something like sudo apache2ctl restart –  rubo77 Dec 11 at 16:15

You just need to stop WebRick by doing a Ctrl+C, if running Mongrel you sould try

mongrel_rails stop

share|improve this answer
    
don't I have to restart it? Just stop is good enough? –  Radek Nov 20 '10 at 11:30
    
Stop is not good enough, my bad there... You should a start after the stop command, or a restart. –  jgemedina Apr 9 '11 at 23:17

Ubuntu (10.04) installs redmine (0.9.3) with passenger. It is passenger that really does restart application using (in /usr/share/redmine):

touch tmp/restart.txt

However, there is another point there. In config/environment.rb, the setting

config.action_mailer.perform_deliveries = false

must be changed to:

config.action_mailer.perform_deliveries = true

Reference: http://www.redmine.org/boards/2/topics/4240

I found it was too much hassle to setup Gmail SMTP, so I've rather setup exim4.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.