Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had Office XP pro (2002) working, but I started to get this message. "Microsoft Office Access has not been installed for the current user. Please run setup to install the application".

I uninstalled Office and reinstalled it completely. Same error again, with all the Office applications.

I uninstalled Office 2002 and installed Office 2003. Same error.

In Microsoft KB I found the error could be due to permission rights, but I am administrator of my machine (Windows XP), so this is not the case.

Here I found that it could be due to a pirated version, but this is a regular version (I have the original CD with the Keys) and the workaround of replacing or deleting MSO.DLL didn't work.

Can anyone please help me?

share|improve this question
    
I actually tried both with an original copy of Office XP PRO (OEM key) and an original copy of Office 2003 PRO (volume licence key). Maybe I have installed them 3 or 4 times, in various pc rebuilds, but I think that Microsoft gives you a much clearer message if you activate the same copy too much times.... –  Andrea Bertani Aug 11 '09 at 21:46

3 Answers 3

Microsoft provided a tool(Office Removal Wizard) to completely remove all Office apps when a manual uninstall did not resolve the issue. I have had to use this many times with older versions of Office. Should be more info here:

http://office.microsoft.com/en-us/orkXP/HA011362891033.aspx

I would also be sure that you install office as a user with admin rights and then run one of the Office applications after the install. This creates some registry keys needed for other users.

share|improve this answer

Permission errors happen even when you're running as administrator. Permissions get changed by badly written software or corruption.

To try and correct this you can use the fixit button here. This tool is used to restore permissions to default settings often solving permissions issues.

I've seen your exact problem a few times and it's most often caused by registry corruption.

First method you can try is to do a manual uninstall of Office and then re-install it.

  • start by running the uninstall as normal.
  • Remove c:\Program Files\Microsoft Office\
  • Open regedit using the run command
  • delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office
  • delete HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office
  • Install Office again.

If you're still having the same issue your profile is likely damaged beyond repair and the option left is to create a new Windows user account.

share|improve this answer
    
Thank you for the help. Unfortunately, I already tried to manual uninstall, using the exact procedure you have described, but it didn't help. I will try the other options, but since I have solved my primary problem (I installed Access on an old W2K PC) I will do it in my spare time (which means not in the near future :-( ) –  Andrea Bertani Aug 11 '09 at 21:40

Is it possible that the OEM Key and Volume License Keys for that have both been revoked by Microsoft?

Depending on where you bought them and through what Channel, they still may be pirated, and Microsoft may have finally gotten around to locking them down. You should call Microsoft's Support line for better help diagnosing the issue.

You may wish to look at http://www.microsoft.com/howtotell/default.aspx?displaylang=en

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.