Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The method described at the end of this blog entry has instructions for making Notepad++ (or any application) the default text editor for IE7's View Source feature. The problem is, the file IE7 sends to Notepad++ has no extension (in particular, does not have an .html extension) and therefore is displayed as plain text in Notepad++. Is there anyway to tell Notepad++ to use HTML as the Language in this scenario? Perhaps the registry value can be modified to pass an argument to notepad++.exe indicating the language to use...

share|improve this question

1 Answer 1

up vote 1 down vote accepted

In Preferences > New document set the default language to HTML. This work either for new files and files without extension.

share|improve this answer
    
Thanks Alberto, I was aware of the default language setting, but I'm not prepared to go that route -- I'd rather keep plain text as the default in general. –  Stephen Swensen Nov 19 '10 at 22:05
    
For files with extensions the proper route would be add the extension in Settings > Style configurator, but it doesn't work for files without extensions (I tried tricks like . and " " and doesn't work). I'm afraid that the New document route is the only way for that files. –  Alberto Martinez Nov 20 '10 at 21:27
1  
OK, thanks @Alberto, not ideal but most of my files do have extensions so this should probably be OK. BTW: to be a bit more detailed, it's Settings > Preferences... > New Document/Default Directory > Default language –  Stephen Swensen Dec 1 '10 at 19:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.