Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I install or update an add-on, Firefox then pops open the add-ons dialog after the next time the browser starts. I have never ever had a use for this, it's just another popup window for me to close. Is there an about:config setting I can enter to stop this from happening?

share|improve this question
    
Something strange happened...I asked two separate questions. The other one disappeared, but Psychoholic answers that other question, not this one. Maybe some moderator didn't read carefully enough and merged them? –  davr Nov 22 '10 at 22:48

4 Answers 4

From: https://forums.mozilla.org/addons/viewtopic.php?p=1881&sid=b8a963f929efff6834f817b6ee621a9b

There are plans to add standardized support for first-run and post-update pages for add-ons: https://bugzilla.mozilla.org/show_bug.cgi?id=459965

Once that is implemented, Firefox can add an option to handle them specially.

Looks like this will be a new feature, hopefully soon.

EDIT: Link info is several months old, so it may already be implemented, however I can't find any such settings.

share|improve this answer
    
This doesn't answer this question. It answers another question I asked that mysteriously disappeared though. –  davr Nov 22 '10 at 22:51

Try typing about:config in the URL, then change extensions.getAddOns.showPane to false. I realize that just removes the add ons pane from the actual tools>add ons window, but maybe if the pane is not there it will not prompt you for updates. You can always change it back if you want to browse or update add ons.

share|improve this answer
    
I just made the described configuration change, and so far it seems to be working well! –  eleven81 Mar 1 '11 at 14:31
    
Excellent! The "blanket fix" to remove the whole pane isn't necessarily the optimal solution, but how often do you browse add-ons really?? maybe a half hour/hour per month? It's an easy toggle anyway. Glad to help. –  08Hawkeye Mar 7 '11 at 19:47

Upgrade to FireFox 4 Beta. The add-ons window is no longer a window, just a tab opened in your normal browser window. If I remember correctly, it also does not pop up the tab after add-ons have been updated.

share|improve this answer

Ok I found a solution that worked for me, I simply dragged the user.js and the user.js.BAK to the desktop, before that I had done the same with the prefs.js and prefs.js.BAK, but that didn't help, so it's apparently the user file that was an error with.

It was the link from cor-el (Firefox forum supporter) that helped me on the way http://kb.mozillazine.org/Preferences_not_saved It's at the bottom titled User.js file locks certain preferences. This article can also help https://support.mozilla.com/en-US/kb/Preferences%20are%20not%20saved

It have still not made a new user.js file, but everything runs fine, hope this can help others to.

share|improve this answer
    
Sorry I thought this was about the problem where the update windows keeps popping up every time FF starts. I don't know how to delete it, I could edit it, but I think that people with this problem will find it course that's how I found it. –  Kim Celinder Jul 22 '11 at 11:45
    
You may edit your answer to make it really answer the original question. Or, alternatively, flag it for moderator's attention, and they will be able to delete it. –  bytebuster Nov 17 '12 at 8:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.