Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been using a Windows XP Pro VM (32-bit, SP3) for months on my work PC (Windows 7 64-bit) with no problems, with a PS/2 keyboard and a standard optical USB mouse.

Today I copied this VM onto my home PC, which is also Windows 7 64-bit but with a G15 USB keyboard and MX518 USB mouse. For some reason the VM does not accept input from the keyboard or mouse, which makes it almost impossible to use. (Unity works but is not an option). Both my home and work PC are running VMware player 3.1.0.

My keyboard and mouse show up as USB devices in the bottom-right of the VMware Player window, and if I click them I have the standard option to "Connect (Disconnect from host)". I have selected this option for the keyboard, and then the VM happily accepts keyboard input, but of course my host PC no longer does.

It seems like VMware is seeing my keyboard and mouse as USB devices and not input devices. I've tried sending the keyboard input to the guest and reinstalling VMware Tools, but that achieved nothing. I'm certain it's a problem with the VM, and not the XP install, as I also can't use F12 to enter the VMware BIOS when the VM is powering up.

share|improve this question

2 Answers 2

I did not have such experiences with VMWare, so shooting in a dark a bit here. From this VMWare KB:

It seems that you should not use them as USB devices at all the way VMWare was designed.

Check this article also:

I found this option there:

usb.generic.allowHID=TRUE

which might help.

share|improve this answer

I have found other facing the same but then here are some solutions that one can try out, just check it out and see if it is helping.

share|improve this answer
    
While that link may answer the question, it's preferrable to include the essential parts here and provide the link only for future reference. –  Indrek Nov 3 '12 at 12:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.