Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to edit UTF-8 documents with vim (7.2 installed via MacPorts, big feautre set, iconv support enabled, multi-byte support enabled) on Mac OS X 10.4 within terminal.app.

Terminal.app is configured to use Monaco font (which has good Unicode coverage) and use UTF-8 as the character set encoding.

Keyboard map is set up correctly. I can enter some localized characters like „zażółć” and even quotes around that… (yeah, and an elypsis).

I've done my best to set up the environment:

LC_ALL=pl_PL.UTF-8
LC_CTYPE=pl_PL.UTF-8
LANG=pl_PL.UTF-8
export LC_ALL
export LC_CTYPE
export LANG

I have no encoding, fileencoding or termencoding set in .vimrc, so that it should default to what's set in the locale.

What else have I missed? I can't enter non-ASCII UTF-8 characters in vim. It is interpreted as single-byte garbage rather than wider UTF-8 characters.

share|improve this question
up vote 4 down vote accepted

Check out this:

(Thanks to Peter Vohmann for this Q&A.) In Terminal.app go the the Terminal (main) menu and choose Window Settings. Select Emulation from the popup menu, un-check the item "Escape non-ASCII characters". Then select Display from the popup menu, set Character Set Encoding to Unicode (UTF-8), if desired. Click on "Use settings as Default."

(from MacVim Site)

As far as I remember, 10.4 Terminal.app has some troubles, when dealing with UTF-8; checking setting above would, probably, help. As an alternative solution, consider using MacVim or iTerm as terminal application.

Update: as Ben Stiglitz mentioned in comments, 10.4 Terminal is OK, but 10.4 bundled shells are not.

share|improve this answer
1  
Terminal 1.5 in 10.4 does fine with UTF-8 if you set your LANG properly. There are some issues with the shells, especially bash and tcsh, that were resolved in Leopard. – Ben Stiglitz Aug 25 '09 at 13:56
    
Unselecting escape non-ASCII characters did the trick. I'll upgrade to snow leopard in a week or two anyway. Thanks – Tadeusz A. Kadłubowski Aug 25 '09 at 18:50
    
Did the trick for me! OS X 10.7.2, homebrew console Vim (to get clipboard support). – Wojtek Kruszewski Dec 17 '11 at 11:33
    
Thanks, this problem stumpted me for a while today, thinking why some characters didn't work no matter what encoding I used. – Johan Feb 7 '15 at 15:41

I don't know about Vim in the Terminal, but I have no troubles entering Korean characters in MacVim. This is with no extra setup, just as it came.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .