Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a PC that has equally severely degraded performance across all browsers (IE, Firefox, Chrome), however the underlying connection seems ok (pings google at 40ms) and the other PC I have on the same hub is fine. Local apps also run fine. I've run the obvious ad-aware, McAffee, CCleaner scans. What could be causing this?

UPDATE:

When running Charles proxy, things go back to normal! Any ideas?

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

Do you have all your browsers set to use a non responsive proxy? Are they all set to use a proxy that isn't working correctly?

share|improve this answer
1  
My assumption is this is what you are talking about: charlesproxy.com If your browsers have been configured to use a proxy (another device/program that intercedes to provide web connectivity/protextion), and it isn't there, your browsers have to timeout waiting for it before they can connect to a website. You likely have auto proxy detect/configuration turned on in preferences in your browsers. In IE go to Internet Options, Connetions Tab, Lan settings (bottom right hand corner) and review what is in the window that opens. Is is configured to look for a script or use a proxy? –  Everett Nov 20 '10 at 14:54
1  
Record the settings to use proxies from all of your browsers. Then remove the settings and see if this fixes it. If it does your proxy isn't running/isn't configured correctly while you use your browser tries to use it. –  Everett Nov 20 '10 at 15:01
1  
Or, @Yarin, you might be using some system wide proxy settings (like on a Mac: somewhere in the network settings) when not explicitly using some other proxy. In Firefox you have many options: 1) No proxy; 2) Auto-detect proxy settings for this network; 3) Use system proxy settings (this is the default setting in Firefox 3.6.4 and above!); 4) Manual proxy configuration. What if you choose 1) there? –  Arjan Nov 20 '10 at 15:13
1  
Arjan's right. AND Maybe when you installed charlesproxy it went through and configured all your browsers to use it, and this is why all your browsers are slow, except when chrlesproxy is running. –  Everett Nov 20 '10 at 15:30
1  
Ah, indeed, I figured Yarin installed Charles after you mentioned the word "proxy", but maybe it was already installed prior to that. @Yarin? –  Arjan Nov 20 '10 at 15:41
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.