Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I would like to copy to the tmp directory on my router, and do not know how to enable SSH to access it.

I am connected to it via LAN and am running OSX Snow Leopard 10.5.6.

share|improve this question

1 Answer 1

Have you tried to search for the official documentation of DD-WRT ?

Here is the topic about SSH and telnet : http://www.dd-wrt.com/wiki/index.php/Telnet/SSH_and_the_Command_Line

This explains how to setup the SSH daemon and authentication methods.

The following wiki article explains how to enable SSH and access your router from the internet : http://www.dd-wrt.com/wiki/index.php/SSH_access_from_internet

Basically, here are the steps :

  1. Ensure SSH Enabled

    • Goto the Services tab and the Services sub-tab on the Web Interface
    • Enable "SSHd" is under the section titled "Secure Shell"
    • 'SSH TCP Forwarding' does not need to be enabled if you just want to connect from the outside to your LAN.
    • Choose an appropriate port (The default is 22, but it is recommended that you change it to a non-standard port above 1024 for security reasons. Remember the port number, as you will need to enter it into your SSH client in order to connect to the router)
    • You can activate (less secure) password authorization and/or (recommended) private/public key authorization. More information about generating the keys can be found here: [1].
    • Save
  2. Enable Remote Access

    • Goto the Administration tab and the Management sub-tab on the Web Interface
    • Enable "SSH Management" under the section titled "Remote Access"
    • Enter the same port number as specified under (4) above. This opens the port in the firewall.
    • Save
    • Reboot Router

Now you will be able to connect to your router's WAN IP from the internet using an SSH client such as PuTTY.

Disabling Remote Access

If at any time you wish to disable SSH access from the WAN, - Goto the Administration tab and the Management sub-tab on the Web Interface - Disable "SSH Management" under the section titled "Remote Access" - Apply Settings

SSH Password

  • When asked for the username, enter root (even if you changed username in web interface)
  • When asked for the password, enter your router's password

Hope this helps !

share|improve this answer
    
While these links may answer the question, it is better to include the essential parts of the answer here and provide the links for reference. Link-only answers can become invalid if the linked page changes. –  Madara Uchiha May 21 at 8:45
    
Corrected my answer, with the steps. –  Ob1lan May 21 at 8:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.