Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

First, I'm running Windows XP SP3 on a dell laptop. The wireless card in it works perfectly fine.

When I run ipconfig with the wire plugged in I get both connections displayed:

ipconfig
Wireless
IP Address: 192.168.1.101
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.1.1

ipconfig
Wired
IP Address: 192.168.1.100
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.1.1

When I have the cable disconnected I can ping my other computers and receive reply's

ping ComputerName
...
Reply from 192.168.1.102: bytes=32 time=1ms TTL=128
...

However, when the cable is connected it says:

ping ComputerName
Ping request could not find host...

On the flip side, I can

ping 192.168.1.102
...
Reply from 192.168.1.102: bytes=32 time=1ms TTL=128
...

My network is four computers plugged into a Linksys wireless router.

Any ideas why the wired connection does not recognize my computer names?

share|improve this question
    
+1 for interesting question. You might want to fiddle with wireless user isolation/AP isolation on the router. –  Ciaran Aug 11 '09 at 19:08
add comment

2 Answers

up vote 1 down vote accepted

Quite possibly your computer is confused about which interface to use when both wired and wireless are active. You've found the workaround -- disabling wireless when wired is active -- but here's a proper fix.

TCP/IP has an "interface metric" available in the Advanced protocol settings for each interface. Given two network adapters on the same network, Windows uses this interface metric to decide which one to use. The adapter with the lowest metric gets used first. So to fix this, assign a higher metric to your wireless adapter.

  • Open Network Connections.
  • Select your wireless connection, right-click, and open the Properties.
  • In the Protocols listed, select Internet Protocol (TCP/IP) and click the Properties button.
  • Click the Advanced button.
  • You should now have the Advanced TCP/IP Settings window open, on the "IP Settings" tab. Uncheck "Automatic metric", and add a number (like "25" or "30") into that box. Click OK.

Now do the same for your wired interface, and set it's metric to a lower number (like "15" or "20").

Here's an article with more detail on XP's automatic metric.

share|improve this answer
    
Thanks, this worked perfectly –  Nathan Koop Oct 16 '09 at 18:10
add comment

I would guess the router is confused when the same computers registers through a wireless and wired.

Also you can try flushing your DNS cache. Tray ipconfig /flushdns then try and ping the other computer. This will force your machine to lookup the ip address of the given computer from the dhcp server.

Another piece of useful information is what does the computer do when the wireless is turned off and the network cable is plugged in?

share|improve this answer
    
Gosh, I'd like to think I'm smart, but seriously. I first plugged in the wire and after that registered as a connection I turned off the wireless connection and it worked perfectly. Thanks. –  Nathan Koop Aug 11 '09 at 19:30
    
btw I didn't run the ipcofing /flushdns –  Nathan Koop Aug 11 '09 at 19:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.