Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have got an external hard drive Seagate 320 Gb that I use inside a Trust 3,5' case.

Device is not showing up in Computer folder, nor in Disk management.

I tried to look for partition with Active @Partition and Runtime GetDataBack software but the device is not found by these softwares.

Any hint on how to format this HDD in order to use it again? (no data save needed)

Thanks 4 all your help!!!

P.S. Ask for any additional info

share|improve this question
up vote 3 down vote accepted

Have you tried another case? Or make sure it's plugged into a USB 2.0 slot, might be not enough power going to the drive.

You can try removing the drive from the case and plugging it directly into the pc into a free SATA/IDE port (whatever your drive is). The BIOS if nothing else will pick up the drive. If it does, FDISK should be able to delete the partition, create a new and format the drive if need be (Directly from DOS, not a CMD prompt within Windows)

share|improve this answer
QuiXilver, I am terribly sorry for the delay in approving your answer... – Mauro Sep 22 '15 at 15:06

If you have reason to doubt correct operation of your USB ports, you can try connecting at a friend's PC. Also, if you need to connect to eSATA as well as USB, that could be a factor as well. When in doubt, check the manual of the Trust case to get some guidance.

share|improve this answer

If the disk doesnt show, you will be not able to format it...

In my experience you can have problems if you are using a different USB cable than the one that came with the disk.

I had a problem with a 1Tb Toshiba drive. It was formatted in Mac, and when connected to a Win 7, it showed as a DVD drive, so I was not able to format or delete any partition. At the same time I couldnt read any information, the drive showed like empty.

I had to connect the drive to a Linux box, delete the partition, format in FAT and then I was able to connect the drive in Win 7 and format again in NTFS

I hope this gives you some ideas.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .