Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Bash readline has a setting called blink-matching-paren that is not working for me. If I type an open parenthesis on the command line, then some text, then a close parenthesis I don't get any blinking. Parentheses matching does work for me in vim and emacs -nw.

Here are the settings and versions, etc.:

$ bind -v | grep blink-matching-paren
set blink-matching-paren on
$ set -o | grep -E '\<(emacs|vi)\>'
emacs           on
vi              off

Various combinations of:

  • Bash 4.0.33(1)-release
  • Bash 4.1.9(2)-release
  • Bash 3.2.51(24)-release
  • mintty 0.9.2
  • PuTTY 0.60 (with and without "Enable Blinking Text")
  • xterm 243
  • gnome-terminal 2.28.1
  • TERM=xterm
  • TERM=xterm-256color

What do I need to do to make parentheses matching work in Bash on the command line?

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

Try setting that in .inputrc, like:

$ cat ~/.inputrc
set blink-matching-paren on

Somehow this setting does not work for me when set interactively, but works fine that way.

share|improve this answer
    
That's just totally bizarre. It works. I added that and then did Ctrl-x Ctrl-r to re-read .inputrc and it worked. The weird thing is that bind -v showed that it was already set. By the way, try it with quotes from the command line: bind 'set blink-matching-paren on' - that works for me, too. –  Dennis Williamson Nov 22 '10 at 20:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.