Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I created an FTP mapped drive on Windows 7 "add network location". It works fine except for one problem. The file transfer rate is way slower than FileZilla. Same local machine, same remote server, 45MB takes 5 minutes with the Win7 Network Place and 1:20 with FileZilla. I repeated the test 5 times over a couple of hours to rule out variations in network. Each test was to transfer with Network Location, then immediately after transfer with FileZilla. Each time the difference was huge, and the times were just about the same for each test pair.

Does anyone know why this is (apart from "Microsoft is stupid" or something like that)? I mean, is there something I need to do to my system to get the performance I should be getting? This is Windows 7 Professional 64bit, Xeon 4-core 2.53GHz, 6Gb RAM, 8 Mb/s outbound net speed (measured with SpeedTest.net).

share|improve this question
2  
Everything else aside, to have a really scientific test you need to vary the order in which you make the transfers: sometimes use Windows first, sometimes use FileZilla first. –  Joel Coehoorn Dec 12 '11 at 15:03
    
From my experience: Our hosting provider uses WinServer 2003 and the MS FTP server, it's horribly slow and gives me time-out errors but when I try another ftp server hosted on Red Hat Linux I get a fast upload experience in Explorer. I created a dump with Wireshark but there isn't anything out of the ordinary. –  ZippyV Dec 16 '11 at 15:12
add comment

4 Answers

up vote 11 down vote accepted
+100

You can't do this, it has to do with very low buffer sizes that you can't change.

Internet Explorer and Windows Explorer have a static buffer size of 4096 bytes that can't be changed, in comparison to that Filezilla has a buffer size of 256 KB. The buffer size of Filezilla is thus 64 times biffer than that of Windows Explorer, and that explains why it capable of doing much faster transfers.

When this buffer gets filled, which goes very fast for 4096 bytes, it starts delaying loading additional data. So rather than loading a full 256 KB and sending that it only loads up to 4 KB. This takes down the upload speed as some delay is introduced.

You can change a thousand network and I/O settings but it will likely not have much effect. FTP programs have way better support as well as features such as simultaneous transfers and resuming a failed transfer, which makes Windows Explorer the wrong tool to be used in this case. So, Windows Explorer isn't really made to do FTP transfers. On the other hand, one could assume a widely used file manager to be capable of doing FTP transfers, but they haven't came around to implement better behavior...

Not really legal, one could reverse engineer and try to patch the value! But why if one has Filezilla? :)

share|improve this answer
2  
This is true. So few users use FTP on Windows, I would get annoyed if Microsoft decided to spend time on this. Better off spending time on things that help the whole user base, like Skydrive integration. 25GB free and I'm stuck using WebDAV? –  surfasb Dec 17 '11 at 22:29
add comment

Some ideas :

  1. Disable IPv6
  2. Disable Remote Differential Compression
  3. Disable Task Offload settings and several possible other settings

This Microsoft article recommends :

  1. Enable flow control in the transmit (Tx) and receive (Rx) directions :
    In the Properties of your network adapter, Advanced tab,and enable Flow control in the Tx and Rx directions (select the Rx & Tx Enabled option if it is available).
  2. Change the link speed to 100 Mbps Full Duplex :
    Same as above, for the 100 Mbps Full Duplex setting.
share|improve this answer
    
That said, I must confess that I avoid Windows Explorer like the plague on network. Interesting to know if one can manage to speed it up. –  harrymc Dec 12 '11 at 19:08
add comment

this could be it: http://support.microsoft.com/kb/555564 to be sure this post is a bit dated
it that doesn't fix it, just know you aren't the only one...they haven't sorted it out yet: http://social.technet.microsoft.com/Forums/en/winserverPN/thread/bb8ac7dd-e19c-4325-8f45-cd366c4da53f

Also, I am truly sorry for your plight, but if MS wants me to fix a commercial product, they can A offer a bounty or B hire me.

share|improve this answer
    
The first one appears to be about (ancient) servers that use IDENTD. That's ancient because reverse DNS is a joke. I doubt I'm alone because this is a nearly fresh install on a clean/reliable system and network. Lessee if anyone else has ideas. Thanks. –  Bob Denny Nov 23 '10 at 4:16
add comment

for both FTP and the "web-client" that sharepoint uses, we have noticed a HUGE increase in speed by going to internet explorer's options, connections tab, LAN settings, and unchecking "Automatically detect settings". It was constantly looking for a proxy server (which we don't have) and really slowing thins down. I don't know if that would speed it up once the transfer has started, but might speed up the browsing of folders.

Also, is IE doing a text transfer, and mozilla doing a binary? Its easy to tell with a tool like wireshark.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.