Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

hey, i have a dell inspiron 1545 (the one without web cam and so on), it originally had Vista, was "upgraded" to XP, and now has Ubuntu 10.10.

Before i installed 10.10 when I would watch a movie or a youtube video all was well and good, but since the change when my mouse is idle the video gets all wonky, it will skip, pause, move around, and so does the audio.

But when the mouse is moving all is well, any ideas? also, from time to time the mouse will freeze.

share|improve this question
    
Why have you put the word 'communism' in the title? –  paradroid Nov 22 '10 at 23:31
    
its a word i use instead of expletives –  Dacota Nov 23 '10 at 0:31
    
Someone with editing power please change the title. That is not appropriate. –  frabjous Nov 23 '10 at 0:52
    
how do you figure? and if i can change it let me know, i will (im kinda new) –  Dacota Nov 23 '10 at 0:58
    
figured it out, sorry –  Dacota Nov 23 '10 at 0:59
show 1 more comment

2 Answers

In power management options turn off throttling the CPU. This might be done in bios or power options.

share|improve this answer
    
thank you sir, have you any idea on the mouse freeze? –  Dacota Nov 23 '10 at 0:33
    
when the mouse is moving your desktop is "active" so it doesn't throttle the CPU. –  hbdgaf Nov 23 '10 at 0:39
    
it freezes randomly, as in, wont move, its an issue aside from the video skip/chopiness, i find that using the arrow keys or the tabs key unfreezes it, but only for a short while –  Dacota Nov 23 '10 at 1:08
    
mouse freezing, if cpu throttling doesn't fix it, I would ask a separate question on askubuntu.com there are some devs on the site that might know far more than I –  hbdgaf Nov 23 '10 at 1:09
    
thankee kindly sir –  Dacota Nov 23 '10 at 1:16
show 1 more comment

I was able to fix this exact problem starting the kernel with the 'nohz=off' option:

nohz=   [KNL] Boottime enable/disable dynamic ticks
        Valid arguments: on, off
        Default: on

(source: http://www.kernel.org/doc/Documentation/kernel-parameters.txt)

Instructions for grub2: http://ubuntuforums.org/showthread.php?t=1366354

Relevant article: http://news.cnet.com/Linux-coders-tackle-power-efficiency/2100-1007_3-6192865.html

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.