Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

after last hard restart My linux broke and now I can't see icons on several folders, files and buttons. How can I fix these ?

In mozilla I can't see all icons like refresh or back. In Applications menu I can't see icons next to first 7 elements. How ever System tools, Universal access, Wine and ubuntu center have their icons. There are also more cases like that in other menus and apps.

What can be solution ?

share|improve this question
3  
you really should give more informations. –  shellholic Nov 23 '10 at 21:05
add comment

3 Answers

up vote 5 down vote accepted

You can Repair Linux ext2 or ext3 file system by doing following steps.

File system must be unmounted, you cannot repair it while it is running. Take system down to runlevel one (make sure you run all command as root user):

# init 1

Unmount file system, for example if it is /home (/dev/sda3) file system then type command:

# umount /home

OR

# umount /dev/sda3

Now run fsck on the partition:

# fsck /dev/sda3

However be sure to specify the file system type using -t option. Recenly one of our sys admin run the command on ext3 file system w/o specifying file system. Result was more corruption as fsck by default assumes ext2 file system.

# fsck -t ext3 /dev/sda3

OR

# fsck.ext3 /dev/sda3

fsck will check the file system and ask which problems should be fixed or corrected. If you don't wanna type y every time then you can use pass -y option to fsck.

# fsck -y /dev/sda3

Please not if any files are recovered then they are placed in /home/lost+found directory by fsck command.

4) Once fsck finished, remount the file system:

# mount /home

5) Go to multiuser mode

# init 3

Hope this would help

share|improve this answer
1  
+1 for stating fsck assumes ext2 by default –  bbaja42 Nov 23 '10 at 20:53
add comment

If one kernel of Linux is unstable, then you should be able to boot up into a slightly older, more stable one. I have mine set on dual-boot, so you always have to select which Linux kernel to use. If that's not your case, then you should be able to push one "F" buttons (e.g. F12) to pull up the bootup menu. You could also try booting up in safemode to try and fix the problem. Or it may just be a matter of restarting the system again...try just simply restarting, then if that fails try some of these other options.

share|improve this answer
    
It's not unstable. I don't see most of icons. –  oneat Nov 23 '10 at 21:01
    
If your 'show desktop' setting were turned off, this will restore it: Code: gconftool-2 --type bool --set /apps/nautilus/preferences/show_desktop 'true' *You have to logoff then log back on for this to take effect. This may fix your problem? –  Mr_CryptoPrime Nov 23 '10 at 21:03
    
for example I can see icon next to Soun & Video –  oneat Nov 23 '10 at 21:18
add comment

I know that it could sound a little odd but you could delete your ~/.gnome, ~/.gnome2, ~/.nautilus and ~/.gconf with

rm -r ~/.gnome ~/.gnome2 ~/.nautilus ~/.gconf

to restore the settings to a default ubuntu's gnome.

If you have some configuration that you may want to put again in place, remember to do a backup: as simple as

cp -r ~/.gnome ~/.gnome2 ~/.nautilus ~/.gconf

share|improve this answer
    
It doesn't work. I still can't see icons. –  oneat Nov 24 '10 at 15:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.