Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Google Apps set up on domain A. I have an email set up at domain B.

Outlook is rigged in the usual fashion directly to domain B. I'd like to avoid using Outlook and move everything over to Google Apps, so I set up a forward from my address on domain B to domain A.

Google Apps is still set to use domain B's SMTP server.

When I send email via Outlook, it works fine. But when I send email via Google Apps to one particular domain, domain C, the mail never reaches its destination. Here's the response ostensibly from mailer-daemon@googlemail.com (identifying information obfuscated for privacy):

Delivery to the following recipient failed permanently:

    recipient@domainc.com

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 550 550 Unrouteable address (state 14).

----- Original message -----

MIME-Version: 1.0
Received: by 10.229.85.196 with SMTP id p4mr6665886qcl.132.1290550172859; Tue,
 23 Nov 2010 14:09:32 -0800 (PST)
Received: by 10.229.239.11 with HTTP; Tue, 23 Nov 2010 14:09:32 -0800 (PST)
X-Originating-IP: [67.255.***.***]
In-Reply-To: <***@google.com>
References: <***@mail.gmail.com>
       <***@google.com>
Date: Tue, 23 Nov 2010 17:09:32 -0500
Message-ID: <***@mail.gmail.com>
Subject: Re: Delivery Status Notification (Failure)
From: Steven Xu <steven@domainb.com>
To: Recipient <recipient@domainc.com>
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

I would have thought that sending it via the same SMTP server would produce the same results. I can tell the connection between Google and the SMTP isn't broken since I can send email to any other domain besides domain C.

Any idea how this is happening and what I can do address it? I'm just opening up Outlook every time I need to send mail now, but this isn't practical.

share|improve this question
    
It would help to see the mail as sent by Outlook and the mail as sent via Google Apps. They're probably sending some header or handling the SMTP conversation differently. . –  Gilles Nov 24 '10 at 0:25
    
Thanks. I'm having a hard time understanding the headers above. Does this failure suggest that there's a problem communicating with the initial MTA (ostensibly the SMTP server for domain B)? –  Steven Xu Nov 24 '10 at 4:39
    
I know you probably won't see this, but have you tried sending mail via both Outlook and Google Apps to some other domain and checking the headers for differences? That's the only thing I can think of that might cause this type of thing. –  Hello71 Feb 8 '11 at 23:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.