Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some applications that I pin to the taskbar, the icon gets duplicated when an instance of the application is running.

For example, in the screen shot below you see there are two icons for VMWare Player (icons all the way to the right).
Windows 7 Task Bar Image
The first (left) icon for VMWare Player is the one I pinned to the task bar.
The second one (right) is linked to the running instance of VMWare Player.

If I start another instance, then gets grouped with the second icon. For most other programs (like Google Chrome in the screen shot below) the running instances just get grouped with the original pinned icon.

Can I make VMWare Player behave the same way?
Why does it behave differently anyway?

share|improve this question
    
VMWare is probably not aware of the Windows 7 guidelines. Perhaps it sees each VM as a distinct application, running in its own memory space, but I'm guessing. I'd just learn to live with it. –  user3463 Nov 25 '10 at 5:25

3 Answers 3

up vote 26 down vote accepted

Two possible reasons and a solution...

Reason 1

I believe it something about do with the program not taking advantage of Windows 7 features (or APIs). Since this may be the case, Windows thinks it is two different programs. You will have to wait until VMware Player updates its software to take advantage of this new feature. This is the same problem I once had with Google Chrome. After a Google Chrome update, it was resolved.

Reason 2

Another reason, you could have pinned the shortcut of the file instead of the actual program. Find actual program, then right click it and select Pin to taskbar.

Temporary Solution

If the first reason is the case then here is a temporary solution. Open up the program, so that you have duplicate icons. Then right click the duplicate icon (the new one) and click Pin this program to taskbar. Next, right click the original and select Unpin this program from taskbar.

share|improve this answer
2  
Reason two worked for me. Strange because I've used the "drag the shortcut to the task bar" method for other programs and not seen this behavior. But I just opened up VMWare and unpinned the original then pinned the running instance and it behaves as expected now. THANKS! –  Chaulky Nov 26 '10 at 23:03
    
Reason 2 seemed to work for me with Outlook 2013 –  LameCoder Jan 8 '14 at 15:30
    
Reason 2 worked for me with iTunes. Good catch! –  Fillip Peyton Jul 1 '14 at 4:07
1  
Temporary solution work for me. Wonderful! –  Ifan Iqbal Oct 26 '14 at 12:22

http://www.euclidnet.com/how-to-fix-duplicate-taskbar-icons/ solved it for me:

Taskbar icons get duplicated when a shortcut is pinned to the taskbar, rather than the program itself. The solution is to find and remove the extra shortcut. The most straightforward way to do this is simply to right click and “Unpin” all the icons for the program in question, launch the program via the Start Menu, and then right click the running program on the taskbar to re-pin it.

Sometimes we’ve run into situations where this doesn’t resolve the problem. There’s usually a hidden shortcut that is being referenced by the running program. In this case, the solution is to “Show Hidden Files” in Windows Explorer, and navigate to the system path for taskbar shortcuts. This path is : C:\Users\%username%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar – there you can attempt deleting the shortcut manually, and re-adding it once again.

share|improve this answer
1  
Nice find! And, weird: the linked February 2014 article has the same screenshot as the question...!? –  Arjan May 13 at 13:48

Had this issue with Eclipse Mars 64 bits on Windows 10 Pro x64 Insider Preview Build 10130. The only way I managed to fix that is by executing Eclipse as it was a Windows Vista app:

  1. Remove any pinned icon to fom the taskbar

  2. Right click on the Eclipse executable -> Properties -> Compatibility tab -> Compatibility Mode

  3. Check Run this program in compatibility mode for

  4. Select Windows Vista (any of them).

  5. Execute Eclipse by clicking on the executable and pin it when it's fully loaded.

I didn't need to add the -vm flag in neither the shortcut (C:\Users\[Your User]\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar) or the eclipse.ini file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.