Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I don't use iTunes and I won't ever. How do I block iTunes from creating the folder ~/Music/iTunes/Album Artwork/Cache?. I can't find the background process that is responsible for it.

Thank you for your time.

share|improve this question
1  
you don't wish to uninstall itunes ? – mic84 Nov 24 '10 at 15:03
    
@mic84: I already uninstalled iTunes, the folder kept appearing. – gulbrandr Nov 24 '10 at 16:14
    
I don't tink your issue is fixed. I don't have QL Folder Xray enabled, and the folder is created anyway. Try again later (not every time you use QL on an MP3 with cover art the folder is created). – Daniel Beck Nov 24 '10 at 19:17

Remove write permissions from yourself.

Terminal:

chmod 500 ~/Music/iTunes/Album\ Artwork/Cache

share|improve this answer
    
He doesn't want the folder to exist. Creating it to withdraw permissions might sound counterintuitive in this case. – Daniel Beck Nov 24 '10 at 16:13
1  
thanks, but unfortunately your solution does not work. I fixed my problem by disabling quicklook on folders using the following command in the terminal: defaults write com.apple.finder QLEnableXRayFolders 0 – gulbrandr Nov 24 '10 at 16:45

It is also created when QuickLooking an MP3 file (not always, but twice for me in two hours) -- I'd say it's futile (if it's just QuickLook, you can workaround that using Finder Get Info preview).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .