Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

XP Pro version has both wireless and LAN connections. Both work well for all traffic(web, mail, update servers, telnet... etc.) However both Skype and Hamachi fail to resolve. Opened the firewall forward the ports on the gateway router. Checked the ISP. Even tested other machines with same config. NO issues. Stumped. Ideas?

share|improve this question
add comment

3 Answers

Have you tired turning off your firewall completely? Often random other ports are used for communication

also whats you firewall?

share|improve this answer
    
Yeah turned off the firewall on the router as well as the gateway. *Yes not intelligent but for troubleshooting sort of needed. To no avail. However every other machine in the lab works great with hamachi and skype. –  mikedopp Nov 30 '10 at 18:27
add comment

By fail to resolve I'm guessing you mean failing to connect. Do you have any error logs from the programs you can look at?

How about flushing dns? Run ipconfig /flushdns Do you know what connection the programs are trying to use and what order do you have your connections in (go to network connections then press alt, go to advanced menu, advanced settings and look at the order the connections go in).

share|improve this answer
    
Yeah flushed dns. deleted the IP stack. uninstalled the winsock and the network devices. To no avail. –  mikedopp Nov 30 '10 at 18:28
add comment

The thing that both programs have in common is encryption. Both use encrypted communication. I'm not an expert on encryption, but I would expect that it might mess things up a bit if your computer is set up to use a proxy or if some malicious software is forwarding your internet traffic through a malicious server. Are you able to log into ssl encrypted websites without having to accept new certificates?

Make sure your DNS settings are set to known good DNS servers or DHCP. alt text

Make sure you are not set up to use a proxy server. (In internet explorer, go to tools->Internet Options->Connections->LAN Settings)

alt text

You might also try some of the stuff here to see if you have a virus.

share|improve this answer
    
The machine did have the alureon rootkit. To which it was cleaned off and retested multiple times. Checked for malware and all clean. –  mikedopp Nov 30 '10 at 18:29
    
@mikedopp I've had good luck with spybot search and destroy. It notified me of strange configurations which led me on the right path to fixing various issues. I will assume that you got all the malware off. Try running "route print" from the command prompt and compare it to the "route print" of working computers with the same configuration (multiple network cards). –  James T Dec 1 '10 at 6:53
    
@mikedopp You should also run "tracert google.com" (or some other domain) and compare the results to working computers. If it turns out to be the same, run tcpview from sysinternals and watch for IP addresses for Skype while logging into skype. Then run a tracert for that IP and compare to other workstations. I want to make sure that your traffic is not being redirected in any way. –  James T Dec 1 '10 at 7:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.