Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'll be staying in a hotel for a while. The room has a wired ethernet connection. When I plug my netbook directly into this, I can surf the internet. However, I have a second computer with just an ethernet port, and I would like to have a private hard-wired LAN behind the WRT54G (hardware version 3) that I brought while still being able to access the internet.

I have dd-wrt (dd-wrt.v24_mini_wrt54g.bin) installed on the router. Configured with the most basic settings, I can access the router config page with my netbook, but I can't access the internet. These are the settings:

  • WAN Connection Type: Automatic Configuration - DHCP
  • Network Address Server Settings (DHCP): DHCP Server
  • Start IP Address: 192.168.1.100

I read that some hotels associate the assigned IP to your MAC address upon initially connecting. Although I didn't see any kind of hotel "landing page" when I first plugged in my netbook, I did later attempt to clone the netbook's MAC address with the router and assign the netbook's IP to the router as a static IP address. However, my netbook still wasn't able to access the internet from behind the router with this configuration (although it could still access the router's configuration page). Here are screencaps of the WAN and LAN Configuration for this attempt:

enter image description here

enter image description here

There were a few fields that I wasn't sure what to put, including the Gateway address.

My netbook is running Ubuntu 10.10. It is configured for DHCP on eth0.

This private LAN configuration worked in my home. What could be different about the hotel that would cause it not to work?


NEW EDIT

Ping results: In dd-wrt there is a menu option "Administration -> Commands" that allows you to type in stuff and click "Run Commands". I typed ping -c 3 google.com and it refreshed the page after about 5 seconds with no output. When I typed ping -c 3 173.194.36.104 (the IP address for Google), the output was:

PING 173.194.36.104 (173.194.36.104): 56 data bytes

For curiosity's sake, the output of uname -r was:

2.4.37

I can also log in with telnet, but there is a limited command set available.

share|improve this question
    
Did you try pinging some WAN address from your netbook trough the router? If so, with what results? –  molgar Nov 25 '10 at 15:53
    
Your text contradicts the linked image - you state WAN Connection Type: Automatic Configuration - DHCP, but the image shows the WAN config being set to static. Either set WAN to Auto/DHCP or instead connect your laptop, jot down the IP & gateway it gets allocated and then use them directly with static settings. The gateway is important, because it's where the router sends requests that it gets that are not on it's local network (ie, anything on the internet). –  DMA57361 Nov 25 '10 at 16:16
    
@DMA57361 - The static IP was a distinct attempt from the first attempt that used DHCP. Also, I do not know how to determine the gateway from when the netbook is directly connected to the hotel's port -- the ifconfig command on my Ubuntu netbook does not list a value for "gateway". –  kostmo Nov 25 '10 at 16:31
    
try route -n, the "gateway" value quoted on the line starting 0.0.0.0 is probably the gateway assigned via DHCP which you could try on a static setting (note: I'm not much of a Linux user, so this is from Google - but it does work when I tested it on my virtual machine install of Ubuntu). –  DMA57361 Nov 25 '10 at 19:45

1 Answer 1

up vote 1 down vote accepted

Check to see if the router has internet access.

Log into the management software and somewhere under Diagnostics or Tools or Advanced there should be an option to Ping an outside address from the router itself.

Post the results. Most probably the hotel has some sort of authentication software which doesn't allow for a certain range of MAC addresses accesing the connection, you could always check with reception.

If you aren't able to ping an outside server from the router it means something is wrong. Remember, that you should take care to setup the router as a network HUB, that is, you have to direct WAN trafic to the hotel's DHCP server. I get the feeling that right now your router is attempting to get WAN access through its integrated WAN port which would, of course, fail.

share|improve this answer
    
I have indeed connected the hotel's ethernet port to the "WAN" port of the router (the port labeled "Internet", as opposed to the four numbered ports). Why will this necessarily fail? Will I still be able to set up a private LAN (where the two internal computers are hidden from the outside world through NAT) if I do not use the integrated WAN port? –  kostmo Nov 25 '10 at 16:38
    
+1 for a cogent answer, but...asking reception? REALLY? You seriously think they'll have the slightest idea? –  Shinrai Nov 26 '10 at 15:38
    
Haha, you make a goos point about the reception, but I have to say that I've been positively surprised at some hotels with very helpful receptionists. Obviously they have to call their "tech-people" but they HAVE been willing to do this for me a few times. Anyhow, I'd try to connect the router through one of the normal router ports forcing the router to work as a network hub. As far as i remember this is how I've gotten this working! –  akseli Nov 29 '10 at 12:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.