Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've encountered a really bizarre problem with my MacBook: when running without the charger plugged into the computer the wifi connection gets really flaky. When the charger is plugged in the wifi works as expected.

The following terminal session pretty much describes the problem. Observe how the ms ping time increases by a factor of 100 when the charger is plugged out.

$ ping 192.168.128.1
PING 192.168.128.1 (192.168.128.1): 56 data bytes
64 bytes from 192.168.128.1: icmp_seq=0 ttl=64 time=1.581 ms
64 bytes from 192.168.128.1: icmp_seq=1 ttl=64 time=1.238 ms
64 bytes from 192.168.128.1: icmp_seq=2 ttl=64 time=1.110 ms
64 bytes from 192.168.128.1: icmp_seq=3 ttl=64 time=1.063 ms
# Charger plugged out here ...
64 bytes from 192.168.128.1: icmp_seq=4 ttl=64 time=222.886 ms
64 bytes from 192.168.128.1: icmp_seq=5 ttl=64 time=142.867 ms
64 bytes from 192.168.128.1: icmp_seq=6 ttl=64 time=371.396 ms
64 bytes from 192.168.128.1: icmp_seq=7 ttl=64 time=293.215 ms
64 bytes from 192.168.128.1: icmp_seq=8 ttl=64 time=521.359 ms
64 bytes from 192.168.128.1: icmp_seq=9 ttl=64 time=135.288 ms
64 bytes from 192.168.128.1: icmp_seq=10 ttl=64 time=363.930 ms
# Charger re-inserted out here ...
64 bytes from 192.168.128.1: icmp_seq=11 ttl=64 time=2.345 ms
64 bytes from 192.168.128.1: icmp_seq=12 ttl=64 time=1.524 ms
64 bytes from 192.168.128.1: icmp_seq=13 ttl=64 time=1.194 ms

The MacBook I'm using is has the following spec: 2.4 GHz Intel Core 2 Duo, running Mac OS X 10.5.8.

Questions:

  • What could be the cause?
  • How would you solve it?
share|improve this question
add comment

2 Answers

up vote 6 down vote accepted

second edit: Apple released a patch for the slow wireless issue here. I will leave the original answer in place in case the patch doesn't fix people's problems.


10.5.8 introduced some serious wifi problems for me as well. The only solution I've found is on Apple's discussion site where someone realised that replacing some system files from 10.5.8 with their counterparts from 10.5.7 fixes the problems. The steps necessary depend on if you have a Time Machine backup from the machine when 10.5.7 was installed.

Firstly, if you have no Time Machine backup from 10.5.7:

edit: I should note that replacing system kexts like this, while unlikely to cause any problems, is highly unsupported. The safest way is to do an Archive & Install from your install discs and update only to 10.5.7 until Apple release an official fix for the bug. blah blah disclaimer etc.

  1. Download 10.5.7 Combo Update
  2. Download Pacifist (the demo will do). This allows you to extract and install files from the 10.5.7 .pkg
  3. Delete /System/Library/Extensions/AppleAirport.kext
  4. Delete /System/Library/Extensions/IO80211Family.kext
  5. Install /System/Library/Extensions/AppleAirport.kext using Pacifist, from the 10.5.7 package.
  6. Install /System/Library/Extensions/IO80211Family.kext using Pacifist, from the 10.5.7 package.
  7. Delete /System/Library/Caches/com.apple.kernelcaches/ folder
  8. Delete /System/Library/Extensions.mkext
  9. Reboot.

Make sure you understand the steps. A mistake here might break your wireless completely.


If you have a Time Machine backup from 10.5.7 you can simply restore the two kexts mentioned above (AppleAirport.kext and IO80211Family.kext) and reboot. That cleared up my wireless issues.

Further discussion on apple.com: 1, 2, 3. These should give more instructions and information.


If you are familiar and comfortable with the Terminal, another method if you have no Time Machine backup: link which has detailed instructions you can copy into the Terminal.


share|improve this answer
    
Thanks for your excellent answer! Turns out Apple rolled out the fix you referenced today to the automatic "Program Update". So fixing this was simply a matter of Apple > Program Update. Thanks! –  knorv Aug 12 '09 at 13:29
add comment

I'm not sure how to solve your problem but something does come to mind.

Is it possible that its some battery saving "feature" where wifi power is decreased? There might be something in the power options.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.