Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently bought an EzCap USB video capture device, which works like a regular capture card except through USB.

Anyway, the device works fine, except the software that came with it to capture the signal is very... bloat-ware like. It's filled with ads and makes a stupid program force itself on startup.

I've tried to capture the media through VLC, but there's a severe input delay. Even though I hate this software (ShowBiz DVD 2) the video capture is perfect, and there isn't any delay or lag. Is there anything better than VLC that can capture video through a device?

Preferably something that I can run full-screen. The ShowBiz DVD 2 software plays nicely and records great, but like I said, it forces some stupid program on start up, and the bigger problem is that the capture screen is like, 2 inches across. It's impossible to play a PS2 game on the thing.

share|improve this question
1  
could try VirtualDub. I am unsure if there is any lag/delay though –  Xantec Nov 26 '10 at 20:21
    
@Xantec how do you capture from a device through virtualdub? I tried it but only saw options for opening AVI files... –  Corey Nov 26 '10 at 20:32
    
quickly searching Google i found this tutorial. I've never used VirtualDub to capture video myself, so i am afraid my own experience is limited in this respect. –  Xantec Nov 26 '10 at 20:53
add comment

1 Answer

up vote 4 down vote accepted

Thanks to Xantec's comments, I was able to get VirtualDub working.

To get the EzCap 116 device to play in VirtualDub, you should download the latest version of the program.

Start the program, then:

  • Go into File > Capture AVI...
  • If no video plays, go into Devices > WDM 2861 Capture
    • if that is already selected, then go to Video > Video sources and select either the Composite or S-Video, depending on what you're using
  • If the video is choppy or does not play, try these:
    • Go into Audio > untick Enable audio playback (having it ticked creates severe frame rate issues)
    • Go into Video > Compression and change it to something other than "No recompression" (you may have to experiment a little)
    • Go into Video > Capture Filter and change the settings (Default is NTSC_M, I have luck with NTSC_M_J and others have luck with NTSC_433. If you live elsewhere in the world, you might try some of the PAL options. YMMV)
  • For best results when capturing, make sure that you're running the capture in a static, unchanging size; i.e., "Stretch to window" is not ticked nor is "Full Screen". If you want to change the size, you can go into Video > Set custom format, but VirtualDub seems to set the size at the device's natural output.
  • If you want to apply a filter to your video as it plays, go to Video > Filter chain > Filter list... and add your desired filters.
  • When capturing, your audio will desync. It's a fairly common problem with VirtualDub. Look around for tutorials on how to edit your video to fix this.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.