Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Notice: This is not about dual booting, I can setup GRUB to dual boot with Windows 7 later. I just need to be able to get into Arch Linux.

Last night I installed Arch onto my computer via netinstall and it all went smoothly, but when I went to reboot... it loaded up the GRUB menu and it listed Arch Linux, but when I select it, I get "Error 15: File not found."

I've been googling and trying various way to fix this problem but I always get the same error.

Some info about my partitions:

/dev/sda:

  1. Windows 7 System Reserved
  2. Windows 7

/dev/sdb:

  1. Data (Movies, Music, etc..)

/dev/sdc:

  1. Seperate Boot Partition
  2. Swap
  3. Seperate Home Partition
  4. Root

/dev/sdd:

  1. PENDRIVE

ubuntu@ubuntu:~$ sudo blkid

/dev/loop0: TYPE="squashfs" 
/dev/sdb1: LABEL="Stuff" UUID="72D6355E32F06BD5" TYPE="ntfs" 
/dev/sda1: LABEL="System Reserved" UUID="A8F8AC7FF8AC4CFE" TYPE="ntfs" 
/dev/sda2: UUID="2A20B02620AFF6CB" TYPE="ntfs" 
/dev/sdc1: UUID="2a23abcf-b29f-4119-b406-0b1817e5c8e1" TYPE="ext2" 
/dev/sdc2: UUID="f3d9ce0d-5953-4f4e-885a-4cd2ebf6b6e9" TYPE="swap" 
/dev/sdc3: UUID="2a53bdc8-7a9a-4dd2-9aef-5b7b4c3e74a4" TYPE="ext4" 
/dev/sdc4: UUID="7b4faa93-98db-49e3-ad41-92e9dc60deda" TYPE="ext4" 
/dev/sdd1: LABEL="PENDRIVE" UUID="0290-E580" TYPE="vfat" 

menu.lst

timeout   5
default   0
color     light-blue/black light-cyan/blue

#===--- Arch Linux
title  Arch Linux
root   (hd2,0)
kernel /vmlinuz26 root=/dev/disk/by-uuid/2a53bdc8-7a9a-4dd2-9aef-5b7b4c3e74a4 ro vga=775
initrd /kernel26.img

#===--- Arch Linux Fallback
title  Arch Linux Fallback
root   (hd2,0)
kernel /vmlinuz26 root=/dev/disk/by-uuid/2a53bdc8-7a9a-4dd2-9aef-5b7b4c3e74a4 ro vga=775
initrd /kernel26-fallback.img

#===--- Windows 7
title         Windows 7
rootnoverify  (hd0,0)
chainloader   +1

fstab

# 
# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
devpts                 /dev/pts      devpts    defaults            0      0
shm                    /dev/shm      tmpfs     nodev,nosuid        0      0
/dev/sdc1              /boot         ext2      defaults            0      1
/dev/sdc2              /             ext4      defaults            0      1
/dev/sdc3              /home         ext4      defaults            0      1
/dev/sdc4              swap          swap      defaults            0      1
share|improve this question
up vote 1 down vote accepted

Your /etc/fstab and blkids don't match:

/dev/sdc1: UUID="2a23abcf-b29f-4119-b406-0b1817e5c8e1" TYPE="ext2"
/dev/sdc1 /boot

/dev/sdc2: UUID="f3d9ce0d-5953-4f4e-885a-4cd2ebf6b6e9" TYPE="swap"
/dev/sdc2 swap

/dev/sdc3: UUID="2a53bdc8-7a9a-4dd2-9aef-5b7b4c3e74a4" TYPE="ext4"
home or root

/dev/sdc4: UUID="7b4faa93-98db-49e3-ad41-92e9dc60deda" TYPE="ext4"
home or root

share|improve this answer
    
if you correct your fstab it should boot – RobotHumans Nov 26 '10 at 23:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .