Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Edimax router that is set up to connect to the internet via L2TP on cable, and on the LAN side it's set up as a DHCP server.

The DHCP server gives correct IP addresses, but it sets itself up as the DNS server. However, it doesn't provide the DNS service. I am sure that it's a problem with the router, because I have two computers on the network with the same problem.

I see that on the WAN side it gets correct DNS addresses from the ISP, so I'd expect the router to either pass these addresses through to the DHCP clients, or to serve the DNS requests itself by forwarding them to the ISP's DNS. However, it apparently does neither, and there is no DNS.

I switched from ADSL to cable last week. On ADSL it connected using PPPoE, and the DNS worked fine.

What can be the problem here?

share|improve this question
    
Quick hack: does your router allows you to set DNS manually? (It should, manufacturers are aware of Google's/OpenDNS server.. but no .local resolution then); did you updated firmware? –  kagali-san Nov 27 '10 at 16:26

1 Answer 1

Silly me...

Rebooted the router... problem solved.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.