Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to connect to my home router web interface from work.

I use dyndns, because I don't have a static IP at home, and it works perfectly from any other place except my workplace (update: I made a mistake, see edit below). When trying to access the web interface from work I get a "500 Server Error" with the code: SERVER_RESPONSE_RESET. I'm not trying to use any protocols such as remote desktop, I'm only trying to access the web interface. I can access any other web page from my workplace with no problems, and I think my router web interface is like any other web page, isn't it?

I thought maybe my work place proxy blocks addresses of services like dyndns, so I also applied another trick. Since I have a web page on my own domain (say www.mydomain.com) which I can access from work, I tried adding a CNAME to my domain which is linked to the dyndns address (router.mydomain.com). This way if anyone enters the address router.mydomain.com from anywhere, they reach my home router web interface, and there's no way of knowing it's a dyndns address (or is there?). However, it still doesn't work from my workplace (I get the same error message).

Any ides?

Edit: I'm sorry to say I made a mistake earlier. I used to be able to access my home router web interface from my old workplace, and I thought it was still possible since I don't recall making any configuration changes. However, after reading the replies, I went over to my old workplace and checked, and it doesn't work from there either. I'm very sorry for giving out wrong and misleading information about my problem. So to summarize: my problem is that I can't access my home router web interface from anywhere.

share|improve this question
    
As right now it's Sunday in most parts of the world, just to be sure: you're not testing using some Remote Desktop through VPN from home, right? (Maybe it's doable, but it might yield some interesting routes then.) –  Arjan Nov 28 '10 at 16:25
    
No I'm not (for now at least), I'm just trying to access the web interface. –  Joe Nov 29 '10 at 20:00

4 Answers 4

Error 500 normally means error on the side of the server, which in your case is the router itself.

The router administration page is not like any other page, since it is served by the router, not by any other computer in your network.

This might be a problem with your router's settings. If you can't find it, you might considering resetting it to initial state (the security-pin method or other). You might also consider updating the firmware (if update is available).

Yet I am puzzled by your claim that it works from elsewhere. If you mean that you can administer your router from outside your network, just not from your work place, then there might be some filter on the company's firewall that is blocking you. You might try changing the way that you are accessing it, such as page-name (if possible in the router's settings).

share|improve this answer
    
Error 500 normally means error on the side of the server Good thinking, that might indeed suggest there is some communication. @Joe, any chance you're using Internet Explorer, which is infamous for its "Show Friendly HTTP Error Messages" when the server side response is too small? Or maybe IE even shows such messages when the server side response is non-existing? –  Arjan Nov 28 '10 at 12:17
    
I don't think there's a problem with my router's settings, since I can access it from outside my network, just not from my work place. Changing the way that I access it sounds good, but what is "page-name"? To answer @Arjan, I am using Firefox. –  Joe Nov 28 '10 at 14:23
    
@Joe: What brand & model is the router? –  harrymc Nov 28 '10 at 14:31
    
D-Link DSL-2760U –  Joe Nov 28 '10 at 14:40
    
From your manual, this router has many configuration options. What have you configured in the section "Access Control"? –  harrymc Nov 28 '10 at 15:15

[..] a CNAME to my domain which is linked to the dyndns address (router.mydomain.com). [..] if anyone enters the address router.mydomain.com [..] there's no way of knowing it's a dyndns address (or is there?)

Surely people (or firewalls) could see it's a CNAME, like see dig www.superuser.com:

;; ANSWER SECTION:
www.superuser.com.      21600   IN      CNAME   superuser.com.
superuser.com.          9639    IN      A       64.34.119.12

But I don't know how smart firewalls are.

A reverse lookup would reveal your internet provider's DNS settings (not the DynDNS records) -- see dig -x youripaddress Maybe that address has (meanwhile) been blocked? What if you just type that (dynamic) IP address for testing?

To see what accessing from another computer might yield, the Web-Sniffer website might be helpful. Also, while testing, I'd surely recommend to NOT use some Remote Desktop over VPN to get to your work computer from home, and then try to get back to your own router. (Maybe it's doable, but it might yield some interesting routes then, which I guess should be taken out of the use case while troubleshooting.)

share|improve this answer
    
Thank you for comment about CNAME, indeed anyone could see it. I tried my current IP address for testing, and I get the same error. –  Joe Nov 28 '10 at 14:35
    
@Joe, what if you use that IP address (or CNAME) with web-sniffer.net ? –  Arjan Nov 28 '10 at 15:10
    
When trying my IP with port 80 or 443, I get "Error 110: Connection timed out". When using any other port (that I've tried), I get "Error 111: Connection refused" –  Joe Nov 29 '10 at 20:10

most routers block incoming request from external ip's, maybe there's a setting for allowing remote access?

share|improve this answer
    
I have allowed remote access on my router. As I said, I can connect to it from any other place except from my workplace. –  Joe Nov 28 '10 at 9:22
    
sorry, I haven't got that. Is your router-webinterface using port 80? Maybe it's another port to don't mess up with running webservers on your LAN, and this port is blocked with your workspace proxy. –  schöppi Nov 28 '10 at 9:34
    
That seems possible, how do I find out which port my router web interface is using? –  Joe Nov 28 '10 at 14:27
    
@Joe, if you're not specifying a specific port, then your browser uses port 80. When using a specific port, like 8080, then you would be using URLs like http://router.mydomain.com:8080 –  Arjan Nov 28 '10 at 15:14
    
I was wrong earlier about accessing my router from places except my workplace (see question edit), but I still can't find the problem with my router's settings. I can try and access my router with different ports, but how do I know which ones to try? –  Joe Nov 29 '10 at 20:13
up vote 0 down vote accepted

After many attempts by the tech support of my router's manufacturer (D-Link) to help, they have given up. It seems that I simply have a faulty router, and I need to replace it. Thanks again to anyone who has tried to help, and sorry for wasting your time.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.