Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Before I ask question, I've searched but only found ways of copy and paste "formatted cell". That's not what I need.

I want to use an example to explain my requirement:

  1. There are 2 cells in a sheet.
  2. Cell_A's text is "aaaaabbbbb", and "aaaaa" is green, and "bbbbb" is red.
  3. Cell_B's text is "ccccc" and "ccccc" is black.
  4. I want to copy and paste "bbbbb" from Cell_A to Cell_B and keep "bbbbb" in red. But in my environment(Office 2007), "bbbbb" is changed to black as "ccccc", the default format of Cell_B.

Is there an easy way to implement my requirement?

share|improve this question
up vote 1 down vote accepted

Normal way to copy formatted text in Microsoft Office Applications:

  • Select the example text/cell with the wanted format.
  • Click on the Format Painter.
  • Finally select the text/cell which you want to paste format.

Confirmed Here: More information about this topic provide by Microsoft Office Support.

Closest to what you asked:

  • Select the source the cell (not the text)
  • Copy it
  • Select the destination the cell
  • Click the down arrow under Paste from the Home tab of the ribbon bar
  • Select Keep Source Formatting right under the Paste heading

What you are trying to do may not be completely possible. That is probably the closest you will get to what you are asking.

share|improve this answer
Although it doesn't fix my issue, I want to say thank you for the answers. – Landy Dec 3 '10 at 9:10

solution is very simple

copy your desired cells paste at distination, you will find a small tag at the right bottom of pasted cells. by clicking the tag you will several option for your pasted cells. now click on "Match Distination Formitting". I think your problem solved. (Office 2007)

share|improve this answer

You should try right_click -> paste special and check if any of those options works for you. I tried your example and had no problems with a normal paste...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.