Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've brand new HP laptop with windows 7 home premium. I installed VS 2008 + SP1. It works fine. I installed MVC2. But since yesterday, as soon as I open a view to edit, the VS 2008 becomes unresponsive. Every time I reopen, same thing is happening. I can do other things, like add/edit entity model, add/edit class etc..

share|improve this question

migrated from stackoverflow.com Nov 29 '10 at 4:15

This question came from our site for professional and enthusiast programmers.

2 Answers 2

I'd like to add that this also worked well for a situation I ran into recently for some of our Business Intelligence Development Studio (BIDS) users. BIDS, for those who aren't familiar, is a scaled down Visual Studio 2008 instance that can be used to create and deploy SSRS-based reports. However, in order to connect it to, say, TFS 2010, you have to install a number of extra items (Team Explorer 2008, TE 2008 SP1, TE 2008 SP1 Forward Compatibility patch).

Anyway, I and other useres ran into a situation where we lacked the ability to create new BI projects. The only options under the 'File' menu were 'New File' and 'New Team Project'. After closing the client and relaunching using the '/resetsetting' command, I regained the options that most other installs had (File → New → Project, Web Site, Team Project, File).

share|improve this answer

You can try resetting your development environment settings to factory default. Relaunch VS2008 by using the command:

devenv.exe /resetsettings

Obviously you'll lose your customizations to your environment by doing this. You can export them to a file first from the Tools menu → Import and Export Settings. If resetting the settings doesn't work, you can restore them with the command:

devenv.exe /resetsettings [PathToSettingsFile]
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.