Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I try to create an account on the simulator or device, I get a message "game center account services are currently unavailable. Please try again later."

Furthermore, I have never been able to sign in to the game center app on the simulator.

Interestingly, if I reset my device with iTunes, I can then log in to the Game Center app with my regular apple id. But whenever if I log out, then try to create a sandbox account for an app I am developing, it always fails as described above.

Any suggestions?

share|improve this question

migrated from stackoverflow.com Nov 29 '10 at 4:40

This question came from our site for professional and enthusiast programmers.

2  
I see some people are voting to close this. I will say that it sure as hell leaves me stuck in my attempt to create my game center iOS app. I imagine other programmers have encountered the same problem. Additionally, per the faq, questions about software tools commonly used by developers are relevant, and the sandbox is such a tool. – William Jockusch Nov 26 '10 at 17:24
    
Did the two migrate voters even bother to read the question? – BoltClock Nov 27 '10 at 4:08

This is whatt is happening to me I want an answer to this problem

Though i am not a programmer i just want to play games with my friends

I have a post on this site keep looking at it to see if there is an answer http://www.ipodtouchfans.com/forums/showthread.php?t=323173

share|improve this answer
up vote 0 down vote accepted

The problem was caused by my router. If I turned off my firewall, everything worked. Hardly a viable long-term solution. Apple has instructions for fixing this with port forwarding. It turned out my router was too old to get those to work -- so I had to buy a newer router, then implement the port forwarding. That solved the problem.

share|improve this answer

I've gotten this problem when the date on my iPhone 3GS is incorrect. The date seems to revert to January 1st, 1970 if I let the power drain completely. I can't connect to Game Center when the date is too far in the past.

The problem is, I always forget about this clock change problem (which also affects facebook login), and spend a while searching the Internet for answers before I remember the clock bug!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .