Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Last night I installed a Windows 7 Professional version for a Student friend and for some reason it's not using all the 16GB of the machine. By using I mean it states only 8GB is usable.

The version was installed from the MSDN Academy Alliance and is a X64 version. Is there any reason why only 8GB would be usable. It's a brand new machine so it's possible it might not be configured in the BIOS (but it does say 16.0GB (8.0GB Usable).

Anybody have any ideas why this can be the case?

Regards, Jamie

[Edit] Apologies, should have put 64 Bit OS. My mistake.

share|improve this question

migrated from Nov 29 '10 at 11:19

This question came from our site for professional and enthusiast programmers.

I'm surprised it even says 8GB is usable since x86 can only address 4GB. – Leo Davidson Nov 29 '10 at 8:12
@Leo not the case. Windows Server 2008 x86/32-bit supports 64GB of memory. Good read:… – Erik Philips Nov 29 '10 at 8:23
Let me qualify that, x86 versions of client versions of Windows, which is what we're talking about here. :) – Leo Davidson Nov 29 '10 at 8:25
@Leo Agreed Windows 7 x86/32-bit only supports 4gb of memory (…) probably checking the BIOS memory check, and not the task manager memory avail. – Erik Philips Nov 29 '10 at 8:28
Apologies, edited my post. It's a 64 Bit OS. – Jamie Nov 29 '10 at 9:43

3 Answers 3

First things first, is your BIOS updated to the newest version. I've seen posts stating the same problem that was solved by a BIOS Update.
Also can the board support 16GB RAM?
Are all ram stricks matching and are all ECC or NON ECC?

Also with thanks to oKtosiTe:
Does all the memory show up on a 64 bit Linux LiveCD like Ubuntu for example? Have you tried running memtest86+? It could be a defective stick. (Although I personally doubt that as it shows 16Gb detected.

As you mention you have a brand new Asus board, check that the OS isn't limiting your memory at boot. Go into MSConfig, click Boot, click Advanced Options and make sure there is no limit enforced in Maximum Memory. See image below.

alt text

share|improve this answer
Also, does all the memory show up on a 64 bit Linux LiveCD like Ubuntu for example? What about memtest86+? – oKtosiTe Nov 29 '10 at 12:54

You might want to go through your BIOS and check whether you have any settings that may be putting a cap on the memory.

If you can't find anything you should refer to your manufacturer's website and check for any new BIOS updates. It's possible that you're running an older version of their BIOS which doesn't offer full-fledged support.

[EDIT]: Found this: make sure that you did indeed install 7 Professional and not another version which doesn't offer support for larger amounts of ram.

Good luck!

share|improve this answer
Here is a clear table on Microsoft's own website. – oKtosiTe Nov 29 '10 at 12:45

It's definitely Windows Professional X64 Bit. Could be that there is a cap on the ASUS motherboard, but it's a brand new custom spec PC so I'd have expected this to have been sorted. Any idea whereabouts in the BIOS I would need to change anything it's a P7P55D-E ASUS board?

share|improve this answer
Posted a forum thread above. It wouldn't let me put the link in a comment :S It's a long read, but there are quite a few solutions offered. – akseli Nov 29 '10 at 14:07
I'll check all the combinations when I get back home. Thanks guys. I will let you know the outcome! – Jamie Nov 29 '10 at 16:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.