Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Dell Inspiron 1545 running Windows 7 has reached the point where its startup is painfully slow. Normal operating speed is still very good, however.

I keep getting nagged by startup options, like a Java update etc. but these only appear after I read and sent several emails!

What can I use and what can I do do diagnose and audit my startup processes, in order to trim off all the unnecessaries?

share|improve this question
up vote 8 down vote accepted

Soluto can help you. It's free and really helpful.

share|improve this answer
Soluto is good for preventing or delaying programmes from running at boot time. It references a database put together by other users and professionals to recommend what to allow, what to delay and what to stop altogether. – Tog Nov 29 '10 at 12:03
+1 for Soluto, I was going to add that as my third thing but you beat me to it – Joe Taylor Nov 29 '10 at 12:03
Soluto is not only a great tool, but a really good example of a fine WPF based interface. – ProfK Dec 1 '10 at 4:45

First thing. As your Laptop is a dual Core system make sure you are using both cores during the system boot. To do this:
1. Type “msconfig” (without quotes) in Vista or Windows 7 start menu search box and hit enter.
2. Click Continue if you get a UAC prompt.By default, you won’t get a UAC prompt in Windows 7.
3. Navigate to “Boot” tab and click on “Advanced options” button.
4. Check the box named “Number of processors” and also select the number of processors from the drop down box.

You could also try this: Enabling the Boot-Only fetching feature.
Warning Registry modifications ahead

Click Start.
Go to the Search programs and files textbox, type regedit.
Click Regedit.exe
If the UAC window appears, click Yes.
In the registry, locate this subkey: HLKM\ SYSTEM\CurrentControlSet\ Control\SessionManager\MemoryManagement\ PrefetchParameters.
In the right pane, double-click EnablePrefetcher.
Change the value to 2 and click OK.
In the right pane, double-click EnableSuperfetch.
Change the value to 2 and click OK.
Exit the registry and restart your computer for the changes to take effect.
Next time you turn on your computer, the prefetcher will reserve more resources to the booting process instead of booting and application launching.

Thirdly, make sure you are not loading a myriad of other programs at boot. You can check while you;re in MSConfig.exe what other programs are loading at bootup. As shown in the image here I've disabled most of mine.alt text

share|improve this answer

Well I had this problem (Dell Inspiron 17 dual) and tried some of the stuff above without any real success. I then went into Service and stopped the Dell services. This worked so well that I went to Control Panel/Programs and Features and uninstalled most of the items starting with Dell. I have left the following:

  • Dell Backup and Recovery
  • Dell Power Manager Lite
  • Dell Touchpad
  • Dell Update

If uninstall is too chancy for you then try the services route and stop the Dell services and make then manual start which should do the trick.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .